Problemas al instalar NumPy y Matplotlib en Mac (leopardo de las nieves)

Habiendo instalado Python 2.7 desde el sitio web de python, desde entonces he intentado instalar NumPy y Matplotlib, pero cuando lo hago, aparece un cuadro que me dice que requiere el sistema python 2.6. ¿Necesito estar ejecutando una versión anterior?

Los árboles de versión de Sourceforge de esos módulos son difíciles para los usuarios de OS X. : PI tenía problemas para instalarlos porque no me di cuenta de que había dmgs creados exactamente para Snow Leopard …

Hay diferentes versiones de los archivos .egg y .dmg, debes prestar atención a la descarga. Si tiene SL, debe instalar estas versiones de NumPy y SciPy . Estoy ejecutando SL en una máquina de 32 bits que tiene Python2.6 Python2.7 y Python3.2 instalados y funcionando bien.

No quiero decir que eres ciego ni te estoy acusando, pero puede suceder que te pierdas la versión binaria correcta. :PAG