Whl no es una rueda soportada en esta plataforma.

Soy nuevo en Python, y estoy intentando instalar algunos módulos / paquetes usando el archivo .whl. El sistema no tiene acceso a internet por lo que todo es local.

Intente instalar numpy:

# /usr/local/bin/pip2.7 install numpy-1.13.3-cp27-cp27m-manylinux1_x86_64.whl numpy-1.13.3-cp27-cp27m-manylinux1_x86_64.whl is not a supported wheel on this platform. 

Entonces, ¿qué me estoy perdiendo?

cp27-cp27m paquetes manylinux de cp27-cp27m son compatibles con un intérprete de Python comstackdo con --enable-unicode=ucs2 .

Para un intérprete comstackdo con --enable-unicode=ucs4 , en su lugar necesita paquetes cp27-cp27mu .