Instalar wxPython en Mac os Mavericks

Estoy en un Macbook Air, ejecutando Mavericks. Hoy descargué wxPython a través de su sitio web, sin embargo, cuando hago clic en el paquete de instalación, obtengo:

wxPython3.0-osx-cocoa-py2.7.pkg” is damaged and can't be opened. You should eject the disk image. 

Cualquiera tiene alguna idea para solucionar esto, gracias.

De acuerdo con # 14523 , el problema es que el paquete no está firmado (y es un paquete de estilo antiguo, que ya no es totalmente compatible, por lo que recibe el mensaje de error incorrecto y la solución habitual para hacer clic en el contexto es Abrir) no funciona).

Hay dos soluciones:

Primero, puede desactivar Gatekeeper (en Preferencias del sistema, Seguridad y privacidad, General, seleccionar el botón de opción “Permitir descargas de aplicaciones desde:… En cualquier lugar”), instalar wxPython y luego volver a activar Gatekeeper.

Alternativamente, puede instalar desde la línea de comando:

 sudo installer -pkg /path/to/wxPython.pkg -target / 

Al igual que con muchos otros paquetes, instale wxpython con brew:

brew install wxpython

Encontré este problema con El Capitán (10.11.2) y probé algunas de las soluciones alternativas que se mencionan en otro lugar (instalar a través de la línea de comandos, permitir la instalación de aplicaciones sin firma, etc.) sin suerte. ¡Usa brew!

La respuesta aceptada no funcionó para mí en macOS Sierra.

Tuve que volver a empaquetar manualmente el paquete original como se describe aquí: https://trac.wxwidgets.org/ticket/17203#comment:8

Use brew * para instalar wxmac usando el siguiente comando.

instalar cerveza –python wxmac –devel

una vez que instale wxmac, cree un enlace simbólico entre el wx instalado y la biblioteca de python.

sudo ln -s /usr/local/Cellar/wxmac/2.9.4.0/lib/python2.7/site-packages/wx /Library/Python/2.7/site-packages/wx

Espero que sea útil para los futuros instaladores.

* Si no tiene instalado Brew antes, instálelo usando el siguiente comando: ruby ​​-e “$ (curl -fsSL https://raw.github.com/Homebrew/homebrew/go/install )”