El módulo de Python no se encuentra a pesar de que el “Requisito ya está satisfecho en Pip”

escribo algo de python en OS X, y dice varios paquetes que instalé con pip “ImportError: no hay peticiones con nombre de módulo”

Al ejecutar solicitudes de instalación de pip

> sudo -H pip install requests Requirement already satisfied: requests in /usr/local/lib/python2.7/site-packages Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/site-packages (from requests) Requirement already satisfied: chardet=3.0.2 in /usr/local/lib/python2.7/site-packages (from requests) Requirement already satisfied: urllib3=1.21.1 in /usr/local/lib/python2.7/site-packages (from requests) Requirement already satisfied: idna=2.5 in /usr/local/lib/python2.7/site-packages (from requests) 

está cometiendo errores en twindb_cloudflare, pedidos, grupo, tarutil y MySQL DB. Puedo ejecutar exactamente las mismas importaciones en otro script (en la misma carpeta) sin error.

Ejecutar en el símbolo del sistema.

 pip list 

Verifique qué versión ha instalado en su sistema si tiene una versión anterior.

Intenta desinstalar el paquete …

 pip uninstall requests 

Intente después de instalarlo:

 pip install requests 

También puede probar si pip no hace el trabajo.

 easy_install requests