pyInstaller no se instala para python3

El sitio web pyInstaller.org parece estar inactivo mientras hago esta publicación.

Estoy tratando de instalar pyInstaller para python3. He probado los dos

“c: \ python34 \ scripts \ easy_install.exe” pyInstaller “c: \ python34 \ scripts \ pip.exe” instala pyInstaller

pero ambos dan:

PyInstaller\compat.py", line 129 if sys.maxint > 2L ** 32: ^ SyntaxError: invalid syntax 

Funciona bien para python27 ¿PyInstaller no es compatible con python3? Si no es así, ¿cómo debo hacer una aplicación independiente de mis scripts pyqt5 para Windows?

PyInstaller 2.1 aún no es compatible con Python 3.x. Tendrá que cambiar a Python 2.xo esperar hasta que el proyecto sea compatible con Python 3.x. Puede verificarlo en la página de PyPI , ya que debería haber actualizado los clasificadores que lo marcan como “Python 3.x” compatible. Actualmente las tags son:

 Programming Language :: Python Programming Language :: Python :: 2 Programming Language :: Python :: 2.4 Programming Language :: Python :: 2.5 Programming Language :: Python :: 2.6 Programming Language :: Python :: 2.7 Programming Language :: Python :: 2 :: Only 

Se ha publicado una twig experimental en GitHub que funciona con Python 3.

Solo descarga o clona eso y corre.

Alternativamente, use esta bifurcación , que corrige algunos errores, por ejemplo, --version-file=... support y PyQt5 multimedia support and print services.

Pyinstaller es compatible con python 3, pero debe instalarse específicamente para esa versión, la forma más sencilla es así (windows / linux):

 pip3 install pyinstaller 

Póngalo en un CMD (windows) o en un terminal (linux). Tenga en cuenta el pip3 . el directorio de instalación de python debe estar en la variable de entorno PATH para que ambos (linux / windows) puedan usar pip.

Una manera fácil de juntar las librerías de python en la variable PATH es marcar la casilla que se muestra a continuación en el instalador.

introduzca la descripción de la imagen aquí