No se puede actualizar python-dateutil en OSX

Estoy intentando instalar Sphinx en OSX, con la esperanza de eventualmente convertirlo en un sitio web, siguiendo esta guía :

He trabajado en macporting, homebrewing, python wheelin ‘, y he descubierto qué es un virtualenv … y si debería usar python 2.7 o 3.X (lo cual no pude entender)

Agregué esto a mi perfil de bash:

export PYTHONPATH=$PYTHONPATH:/usr/local/lib/python2.7/site-packages 

Cuando corro esto:

 python -c "import sys; print('\n'.join(sys.path))" 

Esperaba que regresara simplemente /usr/local/lib/python2.7/site-packages

pero dice lo siguiente:

 /Library/Python/2.7/site-packages/pip-10.0.0b2-py2.7.egg /Library/Python/2.7/site-packages/virtualenv-15.2.0-py2.7.egg /Users/nook /usr/local/lib/python2.7/site-packages /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7 /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload /Users/nook/Library/Python/2.7/lib/python/site-packages /Library/Python/2.7/site-packages /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python 

De todos modos, finalmente obtuve una configuración virtualenv y ejecuté el siguiente comando:

 pip install sphinx 

Resolví un error NumPy, y otro error con seis. Pero no puedo deshacerme del siguiente error:

 jupyter-client 5.2.3 has requirement python-dateutil>=2.1, but you'll have python-dateutil 1.5 which is incompatible. 

Cuando ejecuto el siguiente comando:

 pip install python-dateutil --upgrade --ignore-installed 

yo obtengo

 Collecting python-dateutil Using cached python_dateutil-2.7.2-py2.py3-none-any.whl Collecting six>=1.5 (from python-dateutil) Using cached six-1.11.0-py2.py3-none-any.whl Installing collected packages: six, python-dateutil` 

Eso parece bueno …

Pero cuando trato de instalar la esfinge otra vez, obtengo lo mismo

 jupyter-client 5.2.3 has requirement python-dateutil>=2.1, but you'll have python-dateutil 1.5 which is incompatible. 

Así que entré y probé el siguiente comando:

 sudo rm -rf /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/python_dateutil-1.5-py2.7.egg-info/ 

Quiero eliminar ese directorio, a los directorios NumPy, y a otro directorio dateutil … ¡pero no puedo! No tengo los permisos.

Si alguien tiene una sugerencia profesional sobre qué versión de python usar para mi sitio de esfinge (¿la última versión?), Y cómo configurar un entorno virtual con ** esa versión de python, descubra Numpty y dateutil … Lo haré ¡Estarás siempre en deuda contigo!

EDITAR: acaba de probar lo siguiente:

 sudo pip install python-dateutil Password: The directory '/Users/nick/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag. The directory '/Users/nick/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag. Requirement already satisfied: python-dateutil in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (1.5) pandas 0.22.0 has requirement numpy>=1.9.0, but you'll have numpy 1.8.0rc1 which is incompatible. matplotlib 1.3.1 has requirement numpy>=1.5, but you'll have numpy 1.8.0rc1 which is incompatible. jupyter-client 5.2.3 has requirement python-dateutil>=2.1, but you'll have python-dateutil 1.5 which is incompatible. 

Puedes ver que mi número es totalmente económico también, en 1.8.0rc1. Gracias.