El último ‘pip’ falla con “requiere setuptools> = 0.8 para dist-info”

Al usar la versión reciente (1.5) de pip , recibo un error al intentar actualizar varios paquetes. Por ejemplo, sudo pip install -U pytz da sudo pip install -U pytz resultado un error con:

 Wheel installs require setuptools >= 0.8 for dist-info support. pip's wheel support requires setuptools >= 0.8 for dist-info support. 

No entiendo este mensaje (tengo setuptools 2.1) o qué hacer al respecto.


Información de excepción del registro para este error:

 Exception information: Traceback (most recent call last): File "/Library/Python/2.7/site-packages/pip/basecommand.py", line 122, in main status = self.run(options, args) File "/Library/Python/2.7/site-packages/pip/commands/install.py", line 230, in run finder = self._build_package_finder(options, index_urls, session) File "/Library/Python/2.7/site-packages/pip/commands/install.py", line 185, in _build_package_finder session=session, File "/Library/Python/2.7/site-packages/pip/index.py", line 50, in __init__ self.use_wheel = use_wheel File "/Library/Python/2.7/site-packages/pip/index.py", line 89, in use_wheel raise InstallationError("pip's wheel support requires setuptools >= 0.8 for dist-info support.") InstallationError: pip's wheel support requires setuptools >= 0.8 for dist-info support. 

Esto funcionó para mí:

 sudo pip install setuptools --no-use-wheel --upgrade 

Tenga en cuenta que es el uso de sudo

ACTUALIZAR

En la ventana, solo necesita ejecutar pip install setuptools --no-use-wheel --upgrade como administrador. En Unix / Linux, el comando sudo es para elevar permisos.

ACTUALIZAR

Esto parece haber sido arreglado en 1.5.1.

Primero, nunca debes ejecutar ‘sudo pip’.

Si es posible, debe usar el administrador de paquetes del sistema porque usa firmas GPG para asegurarse de que no está ejecutando código malicioso.

De lo contrario, intente actualizar setuptools:

 easy_install -U setuptools 

Alternativamente, intente:

 pip install --user  

Esto es, por supuesto, para los paquetes “globales”. Lo ideal es que estés usando virtualenvs.