Ubuntu ejecutando `pip install` da error ‘No se pueden construir los siguientes paquetes necesarios: * freetype’

Cuando realizo pip install -r requirements.txt , recibo el siguiente error durante la etapa en la que está instalando matplotlib :

 REQUIRED DEPENDENCIES AND EXTENSIONS numpy: yes [not found. pip may install it below.] dateutil: yes [dateutil was not found. It is required for date axis support. pip/easy_install may attempt to install it after matplotlib.] tornado: yes [tornado was not found. It is required for the WebAgg backend. pip/easy_install may attempt to install it after matplotlib.] pyparsing: yes [pyparsing was not found. It is required for mathtext support. pip/easy_install may attempt to install it after matplotlib.] pycxx: yes [Couldn't import. Using local copy.] libagg: yes [pkg-config information for 'libagg' could not be found. Using local copy.] freetype: no [pkg-config information for 'freetype2' could not be found.] 

 The following required packages can not be built: * freetype 

¿No debería pip install -r requirements.txt Requirements.txt también instalar freetype? ¿Cómo se debe instalar freetype en Ubuntu 12.04 para que funcione con matplotlib ?

Related of "Ubuntu ejecutando `pip install` da error ‘No se pueden construir los siguientes paquetes necesarios: * freetype’"

No. pip no instalará dependencias a nivel del sistema. Esto significa que pip no instalará RPM (s) ( sistemas basados ​​en Redhat ) o DEB (s) ( sistemas basados ​​en Debian ).

Para instalar las dependencias del sistema, deberá usar uno de los siguientes métodos según su sistema.

Ubuntu / Debian:

 apt-get install libfreetype6-dev 

Para buscar paquetes en sistemas basados ​​en Ubuntu / Debian:

 apt-cache search  

p.ej:

 apt-cache search freetype | grep dev 

Redhat / CentOS / Fedora:

 yum -y install freetype-devel 

Para buscar paquetes en sistemas basados ​​en Redhat / CentOS / Fedora:

 yum search  

p.ej:

 yum search freetype | grep devel 

Mac OS X: (a través de Homebrew )

 brew install freetype 

Para buscar paquetes en sistemas basados ​​en Mac OS X:

 brew search  

p.ej:

 brew search freetype 

Tuve que instalar libxft-dev para habilitar matplotlib en el servidor ubuntu 14.04.

 sudo apt-get install libfreetype6-dev libxft-dev 

Y luego podría usar

 sudo easy_install matplotlib 

Una solución es hacer sudo apt-get install pkg-config que encontré en este problema de github .

Ninguna de las respuestas existentes me funcionó para actualizar matplotlib en Ubuntu. Esto es lo que finalmente funciona para mí:

 $ sudo apt-get install build-dep python-matplotlib $ pip install matplotlib --upgrade 

Este comando descargará todas las dependencias.

Para python 2.x

 sudo apt-get install python-matplotlib 

Para python 3.x

 sudo apt-get install python3-matplotlib 

Después de instalar, puedes probar

 (sudo) pip install matplotlib 

En Ubuntu, funcionó después de instalar el paquete blt-dev .

 $sudo apt-get install blt-dev $pip install matplotlib 

Estoy usando Mint y ninguna de estas respuestas funcionó para mí, necesitaba:

 sudo apt-get install build-essential g++ 

Tuve el mismo problema con Python 3.6 en Windows, pero luego cambié a Python 3.5.2 y todo funciona bien.

Este comando sudo apt-get install libfreetype6-dev falló en mi en ubuntu 16.04,
The following packages have unmet dependencies: libfreetype6-dev : Depends: libfreetype6 (= 2.6.1-0.1ubuntu2) but 2.6.1-0.1ubuntu2.3 is to be installed

Así que descargué freetype instalado de la fuente , crédito a esta guía

 $ tar -xvjf freetype-xytar.bz2 # extract the downloaded version file $ cd freetype-xy/ $ ./configure $ make $ sudo make install 

pip install matplotlib a virtualenv y pip install matplotlib y todo está funcionando.