Actualizar python3.4 a python3.6 en ubuntu rompe pip

Estoy intentando instalar python3.6 en mi máquina después de que actualmente tengo python3.4. Sin embargo, después de la instalación, intentar ejecutar pip en python3.6 me da el error:

 Traceback (most recent call last): File "pip3", line 7, in  from pip import main File "/usr/lib/python3/dist-packages/pip/__init__.py", line 59, in  from pip.log import logger File "/usr/lib/python3/dist-packages/pip/log.py", line 9, in  import colotwig, pkg_resources File "/usr/lib/python3/dist-packages/pkg_resources.py", line 1520, in  register_loader_type(importlib_bootstrap.SourceFileLoader, DefaultProvider) AttributeError: module 'importlib._bootstrap' has no attribute 'SourceFileLoader' Error in sys.excepthook: Traceback (most recent call last): File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 63, in apport_excepthook from apport.fileutils import likely_packaged, get_recent_crashes File "/usr/lib/python3/dist-packages/apport/__init__.py", line 5, in  from apport.report import Report File "/usr/lib/python3/dist-packages/apport/report.py", line 30, in  import apport.fileutils File "/usr/lib/python3/dist-packages/apport/fileutils.py", line 23, in  from apport.packaging_impl import impl as packaging File "/usr/lib/python3/dist-packages/apport/packaging_impl.py", line 20, in  import apt File "/usr/lib/python3/dist-packages/apt/__init__.py", line 23, in  import apt_pkg ModuleNotFoundError: No module named 'apt_pkg' Original exception was: Traceback (most recent call last): File "pip3", line 7, in  from pip import main File "/usr/lib/python3/dist-packages/pip/__init__.py", line 59, in  from pip.log import logger File "/usr/lib/python3/dist-packages/pip/log.py", line 9, in  import colotwig, pkg_resources File "/usr/lib/python3/dist-packages/pkg_resources.py", line 1520, in  register_loader_type(importlib_bootstrap.SourceFileLoader, DefaultProvider) AttributeError: module 'importlib._bootstrap' has no attribute 'SourceFileLoader' 

Hubo varios comentarios en Internet acerca de ese error, sin embargo, ninguno de ellos contiene ninguna sugerencia de resolución real. ¿Alguien tiene alguna idea de cómo podría arreglar esto?

Me las arreglé para resolverlo sin instalar nada de las fonts. Esto es lo que hice:

  1. Primero, instale pip para Python3.x (por alguna extraña razón no lo tenía …)

     $ sudo apt-get install python3-pip 

    Es una versión antigua …

     $ pip3 --version pip 1.5.4 from /usr/lib/python3/dist-packages (python 3.4) 
  2. … así que actualízalo a la última

     $ sudo pip3 install --upgrade pip 

    Ahora esta mucho mejor

     $ sudo pip3 --version pip 9.0.1 from /usr/local/lib/python3.4/dist-packages (python 3.4) 

  1. Luego actualizar virtualenvvwrapper

     $ sudo pip3 install --upgrade virtualenvwrapper # ... Successfully installed pbr-3.0.1 six-1.10.0 stevedore-1.22.0 virtualenv-15.1.0 virtualenv-clone-0.2.6 virtualenvwrapper-4.7.2 
  2. Ahora creando un nuevo trabajo virtualenv:

     $ mkvirtualenv -p `which python3.6`  

    pip también funciona:

     $ pip install django # ... Successfully installed django-1.11.2 pytz-2017.2 $ pip freeze Django==1.11.2 pytz==2017.2 

Nota: Ahora me doy cuenta de que es un poco más de lo que pediste, pero (sin saber dónde falló exactamente) supongo que estarás bien después del paso 2.

Tenía el mismo problema. La instalación de python desde la fuente ayudó.

 # Remove existing python 3.6 if installed with apt $ sudo apt-get autoremove python3.6 # Get the source $ wget https://www.python.org/ftp/python/3.6.1/Python-3.6.1.tar.xz $ tar xvf Python-3.6.1.tar.xz $ cd Python-3.6.1 # Configure and install $ sudo ./configure $ sudo make altinstall # Success! $ pip3.6 -V pip 9.0.1 from /usr/local/lib/python3.6/site-packages (python 3.6) 

Edit: desde que descubrí pyenv . Facilita la instalación y administración de diferentes versiones de python. ¡Darle una oportunidad!

Reemplacé Python 3.4 con 3.6 en mis servidores Ubuntu 14.04 y tuve el mismo problema. En mi caso, la causa parecía ser un sistema antiguo:

 $ pip --version pip 1.5.4 from /usr/lib/python2.7/dist-packages (python 2.7) 

Nunca he instalado python3-pip. En su lugar resolví el error de la siguiente manera:

 $ sudo pip install --upgrade pip $ sudo pip install --upgrade virtualenv 

Yo estaba teniendo el mismo problema. Parece que tenía 2 versiones de pkg_resources en mi sistema.

/usr/local/lib/python3.6/site-packages/pkg_resources.py

/usr/lib/python3.6/site-packages/pkg_resources/__init__.py

Trasladar la versión anterior para que mi sistema pudiera encontrar la versión más reciente, la arreglé para mí.

mv /usr/local/lib/python3.6/site-packages/pkg_resources.py /usr/local/lib/python3.6/site-packages/pkg_resources.py.back

No pude resolverlo corriendo

 python3 get-pip.py 

o

 pip3 install --upgrade 

porque allí ya tuve problemas con pkg_resources.py. Además, la reinstalación del paquete python3-setuptools de Ubuntu no ayudó, ya que parece que todavía se instala el de la versión originalmente instalada con el sistema Ubuntu (3.4 en mi caso), pero podría resolverlo instalando manualmente las herramientas de instalación a través de

 wget https://bootstrap.pypa.io/ez_setup.py -O - | python3 

Nota: python3 apunta a mi nueva versión 3.6 de python. Si ese no es el caso para ti, entonces deberías ejecutar

 wget https://bootstrap.pypa.io/ez_setup.py -O - | python3.6 

Puedes resolver este error usando este comando. actualizará tus herramientas de configuración

 python -m ensurepip --upgrade 

Simplemente descargue el archivo get-pip.py aquí y use este comando:

 sudo python3 get-pip.py