pip install numpy (python 2.7) falla con el código de error 1

Estoy instalando numpy a través de pip en python 2.7.9 … Revisé la pip list , y devuelve pip (1.5.6), setuptools (12.0.4) . Corro en Windows 7 de 64 bits y probé versiones de Python de 32 y de 64 bits.

pip install numpy termina con:

 Command C:\Python27\python.exe -c "import setuptools, tokenize;__file__='c:\\users\\jon\\appdata\\local\\temp\\pip_build_jon\\numpy\\setup.py';exec(compile(getattr(tokenize, 'open', open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record c:\users\jon\appdata\local\temp\pip-qnynnf-record\install-record.txt --single-version-externally-managed --compile failed with error code 1 in c:\users\jon\appdata\local\temp\pip_build_jon\numpyStoring debug log for failure in C:\Users\jon\pip\pip.log 

Cuando revisé stackoverflow para otras publicaciones sobre errorcode 1, sus soluciones fueron para asegurarse de tener una versión actualizada de setuptools . Instalé Python 2.7.9 desde el sitio web principal, y viene con setuptools y pip listos para funcionar. Además, me aseguré de que mi sistema los tuviera instalados revisando la pip list .

Así que en lugar de buscar el registro de depuración, el error de la consola me dijo que fuera a C:\Users\jon\pip\pip.log . Es bastante largo, pero cerca del final dice.

 error: Microsoft Visual C++ 9.0 is required (Unable to find vcvarsall.bat). Get it from http://aka.ms/vcpython27 

Fui a esa url, descargué el comstackdor y ejecuté pip install numpy nuevamente. No lanzó el código de error 1 esta vez, pero tuvo un problema diferente. Imprimió un enorme muro de texto en la pantalla, lo que nunca sucedió la última vez que instalé numpy / matplotlib / etc. Imprimió el texto durante unos minutos, luego se congeló y se detuvo.

No estoy seguro de cómo proceder?

Si me ayuda puedo publicar el registro de depuración pip.

Descargue el archivo de la rueda (archivo .whl) desde aquí e instálelo con pip:

  1. pip install wheel para instalar soporte para archivos de rueda.
  2. pip install numpy‑1.9.1+mkl‑cp27‑none‑win32.whl para instalar la rueda.