La instalación de Tensorflow falla con “la versión 3.5 de compiletime del módulo no coincide con la versión 3.6”

Intenté instalar desde pip:

pip3 install --user --no-cache https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-1.4.0-cp36-cp36m-linux_x86_64.whl 

Entonces intenté importar y conseguí:

  Using TensorFlow backend. /usr/lib64/python3.6/importlib/_bootstrap.py:205: RuntimeWarning: compiletime version 3.5 of module 'tensorflow.python.framework.fast_tensor_util' does not match runtime version 3.6 return f(*args, **kwds) 2017-11-10 09:35:01.206112: I tensorflow/core/platform/cpu_feature_guard.cc:137] Your CPU supports instructions that this TensorFlow binary was not compiled to use: SSE4.1 SSE4.2 AVX 

Preguntas:

  1. No entiendo por qué la rueda dice 3.6, pero recibo la advertencia de 3.5

  2. Quiero comstackr para optimizar mi cpu, ¿puedo usar pip para instalar desde la fuente en lugar de desde la rueda binaria?

Related of "La instalación de Tensorflow falla con “la versión 3.5 de compiletime del módulo no coincide con la versión 3.6”"

RuntimeWarning: la versión 3.5 del módulo ‘tensorflow.python.framework.fast_tensor_util’ no coincide con la versión 3.6 del tiempo de ejecución

Este es un problema conocido , que tiene prioridad y es probable que se solucione pronto. En este momento, la solución es usar Python 3.5.

ACTUALIZAR:

El problema se ha solucionado en las comstackciones de tensorflow nocturnas: tf-nightly and tf-nightly-gpu ahora tiene un binario python3.6 creado desde cero para Linux”.

Es decir, el siguiente comando debería funcionar con python 3.6:

 # tf-nightly or tf-nightly-gpu pip3 install tf-nightly 

Su CPU admite instrucciones que este binario TensorFlow no se compiló para usar: SSE4.1 SSE4.2 AVX

Esta advertencia proviene del hecho de que las distribuciones de tensorflow predeterminadas se comstackn sin soporte de extensiones de CPU (más sobre esto aquí ). Si desea obtener un paquete de tensorflow optimizado para la CPU, su única opción es comstackrlo usted mismo . Es un poco tedioso, pero absolutamente factible. La comstackción producirá el archivo de rueda, que puede instalar con solo

 pip3 install /path/to/the/tensorflow.whl 

Pero si solo quieres suprimir la advertencia, esto hará:

 import os os.environ['TF_CPP_MIN_LOG_LEVEL'] = '2' 

Tuve el mismo problema y pude resolverlo instalando la versión 1.3 en lugar de usar 1.4 de tensorflow. Utilice el siguiente comando para hacerlo.

  pip3 install tensorflow==1.3.0 

Encontré el mismo problema y lo arreglé por:

 pip install --ignore-installed tensorflow 

El problema ocurrió porque cumplí con una versión local de tensorflow (para habilitar algunas funciones de la CPU) con Python 3.5 anterior. Instalé Python 3.6 recientemente y el nuevo tensorlfow ya admitía esas características de la CPU, así que acabo de instalar la versión oficial.

Actualización :

Después de alguna actualización de tensorflow el enfoque anterior ya no funciona.

Otra solución es usar un entorno virtual como anaconda para crear un entorno python3.5:

 conda create -n py35 python=3.5 source activate py35 pip install tensorflow 

Para trabajar con ipython o jupyter notebook, asegúrese de instalar ipykernel dentro del entorno virtual:

 pip install ipykernel 

Simplemente instale la versión 1.3 de tensorflow. Problema resuelto.

 pip install tensorflow==1.3.0 

solución 1. la forma en que resolví esto es mediante la degradación a la última versión de python3.5, vaya a python.org descargue la última versión de Python3.5, instálela y luego use pip3 install tensorflow La segunda solución.

solución 2 (también necesita bajar de python3.6 a python3.5. Utilicé Pycharm para resolver el problema, creé un proyecto dentro del editor de pycharm, luego cambié el Project Interpreter de python3.6 a python3.5, para hacer esto También vaya a Archivo> Preferencias y busque Project Interpreter, y desde el menú desplegable cambie de python3.6 a python3.5, haga clic en Apply, espere a que finalice la operación

introduzca la descripción de la imagen aquí y luego en la misma ventana usando el icono +

introduzca la descripción de la imagen aquí

Aparecerá una ventana que le permitirá buscar e instalar bibliotecas de Python fácilmente sin usar pip, en nuestro caso queremos tensorflow, así que solo busque tensorflow, seleccione tensorflow en los resultados de búsqueda y haga clic en Instalar paquete. Esto instalará el paquete.

introduzca la descripción de la imagen aquí

y listo, ya está listo para rodar, ahora tiene instalado tensorflow en su python3.5, tenga eso en cuenta.

Por ahora puede usar la versión de python con menos de 3.6.x porque ahora Tensorflow 1.4.0 no funciona correctamente con python 3.6.x. Será un trabajo rudo.

Este problema se resolvió en ubuntu 17.10 ejecutando

$ conda install tensorflow

Yo uso tensorflow 1.4.0, resuelvo el mismo problema. pero puedes usar tensorflow 1.6.0, ahora.