Error de atributo al instalar con pip

Este es un especialista en fallas, por lo que estoy publicando esta pregunta DESPUÉS de haber examinado y leído todas las publicaciones anteriores sobre este tema.

Ejecutando OSX 10.9 Python 2.7 sin virtualenv

pip install awssh Downloading/unpacking awssh Downloading awssh-0.1.tar.gz Cleaning up... Exception: Traceback (most recent call last): File "/Library/Python/2.7/site-packages/pip-1.5.2-py2.7.egg/pip/basecommand.py", line 122, in main status = self.run(options, args) File "/Library/Python/2.7/site-packages/pip-1.5.2-py2.7.egg/pip/commands/install.py", line 274, in run requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle) File "/Library/Python/2.7/site-packages/pip-1.5.2-py2.7.egg/pip/req.py", line 1215, in prepare_files req_to_install.run_egg_info() File "/Library/Python/2.7/site-packages/pip-1.5.2-py2.7.egg/pip/req.py", line 288, in run_egg_info logger.notify('Running setup.py (path:%s) egg_info for package %s' % (self.setup_py, self.name)) File "/Library/Python/2.7/site-packages/pip-1.5.2-py2.7.egg/pip/req.py", line 265, in setup_py import setuptools File "/Library/Python/2.7/site-packages/setuptools/__init__.py", line 11, in  from setuptools.extension import Extension File "/Library/Python/2.7/site-packages/setuptools/extension.py", line 8, in  File "/Library/Python/2.7/site-packages/setuptools/dist.py", line 21, in  packaging = pkg_resources.packaging AttributeError: 'module' object has no attribute 'packaging' 

Este error se debe a la presencia de una versión obsoleta de pkg_resources . Para deshacerse del error, haga lo siguiente:

  1. Inicie una sesión de python, importe pkg_resources y vea el archivo desde el que se carga:

     In [1]: import pkg_resources In [2]: pkg_resources.__file__ Out[2]: '/usr/lib/python2.7/dist-packages/pkg_resources.pyc' 
  2. Eliminar este archivo (y el archivo *.py asociado):

     $ sudo rm /usr/lib/python2.7/dist-packages/pkg_resources.py* 
  3. ¡Eso es! Vuelva a ejecutar la instalación; se debe completar sin ningún error:

     $ sudo pip install awssh 

Advertencia

Si está en un sistema Linux basado en Debian, este archivo podría haberse instalado a través del python-pkg-resources . Por lo tanto, la actualización o reinstalación de este paquete restablecerá el módulo obsoleto. También tenga en cuenta que está jugando con un archivo que se supone que debe ser controlado por apt .