Python pip problemas de instalación de Requirements.txt

He tenido mucha suerte con pip en el pasado, pero trabajar para instalar algunas cosas en un sistema de televisión me está dando algunos dolores de cabeza. Sigo recibiendo errores como No se encontraron distribuciones en absoluto para algún paquete. Almacenamiento del registro de depuración por fallo en /root/.pip/pip.log

Could not find any downloads that satisfy the requirement somepackage Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-RjqjFW/psycopg2 

Sé que estos paquetes están instalados en el sistema principal, pero es como si no funcionaran en el sistema operativo. ¿Cómo todos ustedes solucionan este problema? Ha sido un día largo y simplemente no entiendo cuál es el problema, especialmente porque funcionan en mi sistema local, funcionan en la instalación principal de python en mi sistema remoto, pero no en el sistema virtual por alguna razón. ¿Algunas ideas?

Aquí están los requisitos, pensé que era un poco intenso para django, pero eso es lo que pip freeze> Requirements.txt me dio

 Babel==1.3 Django==1.7.1 Fabric==1.10.1 Flask==0.10.1 Flask-Babel==0.9 Flask-Login==0.2.11 Flask-Mail==0.9.1 Flask-OpenID==1.2.4 Flask-SQLAlchemy==2.0 Flask-WTF==0.10.3 Flask-WhooshAlchemy==0.56 Jinja2==2.7.3 MarkupSafe==0.23 PAM==0.4.2 Pillow==2.3.0 Pygments==1.6 Scrapy==0.24.4 Sphinx==1.2.2 Tempita==0.5.2 WTForms==2.0.1 Werkzeug==0.9.6 Whoosh==2.6.0 adium-theme-ubuntu==0.3.4 apt-xapian-index==0.45 argparse==1.2.1 backports.ssl-match-hostname==3.4.0.2 blinker==1.3 boto==2.20.1 bottle==0.12.7 certifi==14.05.14 chardet==2.0.1 colotwig==0.2.5 command-not-found==0.3 coverage==3.7.1 cssselect==0.9.1 debtagshw==0.1 decorator==3.4.0 defer==1.0.6 dirspec==13.10 docutils==0.11 duplicity==0.6.23 ecdsa==0.11 flipflop==1.0 guess-language==0.2 guppy==0.1.9 html5lib==0.999 httplib2==0.8 ipython==2.3.1 itsdangerous==0.24 lockfile==0.8 lxml==3.3.3 nose==1.3.4 numpy==1.8.2 oauthlib==0.6.1 oneconf==0.3.7 paramiko==1.15.2 pbr==0.10.7 pexpect==3.1 piston-mini-client==0.7.5 psycopg2==2.5.4 pyOpenSSL==0.13 pyasn1==0.1.7 pycrypto==2.6.1 pycups==1.9.66 pycurl==7.19.3 pygame==1.9.1release pygobject==3.12.0 pyserial==2.6 pysmbc==1.0.14.1 python-apt==0.9.3.5ubuntu1 python-debian==0.1.21-nmu2ubuntu2 python-openid==2.2.5 pytz==2014.10 pyxdg==0.25 queuelib==1.2.2 reportlab==3.0 requests==2.2.1 roman==2.0.0 sessioninstaller==0.0.0 simplegeneric==0.8.1 six==1.5.2 software-center-aptd-plugins==0.0.0 speaklater==1.3 sqlalchemy-migrate==0.9.2 sqlparse==0.1.14 system-service==0.1.6 tornado==4.0.2 unity-lens-photos==1.0 urllib3==1.7.1 virtualenv==1.11.6 w3lib==1.10.0 wsgiref==0.1.2 wxPython==2.8.12.1 wxPython-common==2.8.12.1 xdiagnose==3.6.3build2 z3c.xmlhttp==0.5.1 zope.interface==4.0.5 zope.publisher==4.0.0a4 zope.traversing==4.0.0 zope.viewlet==4.0.0a1 

Veo algunos problemas:

  1. Your requirements.txt es para el sistema base de Python, no para ningún entorno virtual. Django no tiene dependencias externas.

  2. Está utilizando el usuario root para instalar paquetes en su entorno virtual (o está utilizando sudo cuando no debería).

La mejor opción es comenzar desde cero:

 $ virtualenv myvenv ... $ source myvenv/bin/activate (myvenv) $ pip install django ... (myvenv) $ pip freeze > requirements.txt 

Tuve un problema similar, pero el método anterior no funcionó para mí. Se aclaró con una solución bastante más simple:

(venv) $ pip install --upgrade -r requirements.txt

ACTUALIZACIÓN: este comando actualiza todos los paquetes que se han enumerado explícitamente en su archivo Requirements.txt.

Su archivo Requirements.txt es solo una lista de los argumentos de instalación PIP colocados en un archivo. Se utilizan para retener el resultado de la congelación de tuberías con el fin de lograr instalaciones repetibles. En este caso, su archivo Requirements.txt contiene una versión anclada de todo lo que se instaló cuando se ejecutó la congelación de pip.

prueba pip install -r requirements.txt

Funciono para mi

Tuve este problema pero con una causa diferente: tenía una versión anterior de virtualenv. Antes de la versión 1.7, tenía que especificar la opción –no-site-packages al crear el entorno virtual para no incluir paquetes globales.

Dos opciones para solucionar esto, o bien actualizar su virtualenv:

 sudo pip install virtualenv --upgrade virtualenv venv 

O use el antiguo con la opción no-site-packages:

 virtualenv venv --no-site-packages 

Eso arregló mi archivo Requirements.txt.

sudo pip install -r requirements.txt pip install -r requirements.txt o pip install -r requirements.txt funcionó para mí