Tensorflow r1.0: no se pudo encontrar una versión que satisfaga el requisito tensorflow

Quiero instalar Tensorflow 1.o para python en windows.

Esta es información para mi sistema.

D:\>python --version Python 3.5.2 :: Anaconda 4.2.0 (32-bit) D:\>pip3 --version pip 9.0.1 from d:\web\anaconda\lib\site-packages (python 3.5)' 

Pero, cuando ejecuto debajo del comando,

 D:\>pip3 install tensorflow Collecting tensorflow Could not find a version that satisfies the requirement tensorflow (from versions: ) No matching distribution found for tensorflow 

No entiendo cual es el problema …

Y lo intenté de otra manera …

Este es el caso cuando uso Conda.

 (tensorflow) D:\>pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.0.0-cp35-cp35m-win_x86_64.whl tensorflow-1.0.0-cp35-cp35m-win_x86_64.whl is not a supported wheel on this platform. 

¿Cuál es el problema?

Estaba en el mismo problema.

Abajo el comando resolvió mi problema

 pip3 install --upgrade https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.0.0-py3-none-any.whl 

Para encontrar la lista de todas las direcciones URL basadas en la versión de Python y la CPU o GPU, consulte: https://www.tensorflow.org/install/pip

En Microsoft Windows, TensorFlow necesita Python 3.5 de 64 bits. Parece que usas Python de 32 bits.

Tensorflow en windows necesita python 3.5. Puedes seguir los siguientes pasos para activar python 3.5 en anaconda:

  1. Mira qué versión de python tienes: conda search python
  2. Si ya tiene Python 3.5, vaya al paso 3, de lo contrario, utilice conda create -n py35 python=3.5 anaconda para crear Python 3.5
  3. Activar python 3.5 usando activate py35
  4. Ahora instale tensorflow usando conda install tensorflow

Si el paso 4 no funciona, es decir, algo como “tensorflow: no se encontró el paquete”, siga este tutorial para forjar el conda-forge y luego intente instalar el tensorflow usando el paso 4. Funciono para mi

Prueba esto

Instalando con Anaconda

 conda create --name tensorflow python=3.5 activate tensorflow conda install jupyter conda install scipy pip install tensorflow or pip install tensorflow-gpu 

Es importante agregar python = 3.5 al final de la primera línea, porque instalará Python 3.5.

Estaba recibiendo el mismo error

  1. Consigue Python 3.5
  2. Actualiza la versión pip a 9
  3. Instalar tensorflow

Funciono para mi

Desde la salida de la versión de python, parece que está usando Anaconda python, en ese caso, hay una forma sencilla de instalar tensorflow.

 conda install -c conda-forge tensorflow 

Este comando se hará cargo de todas las dependencias, como la actualización / degradación, etc.

Lo hice con:

 python3 -m pip install --upgrade tensorflow