Python 3.4 y 2.7: No se puede instalar el paquete numpy para Python 3.4

Estoy usando Ubuntu 12.04 y quiero usar python 3.4 en paralelo con python 2.7.

La instalación de python 3.4 funcionó correctamente. Sin embargo, no puedo instalar el paquete numpy para python 3 (y como consecuencia no puedo instalar scipy, pandas, etc.).

Utilizando

sudo pip3 install numpy 

escupe el siguiente error:

 File "numpy/core/setup.py", line 289, in check_types "Cannot compile 'Python.h'. Perhaps you need to "\ SystemError: Cannot compile 'Python.h'. Perhaps you need to install python-dev|python-devel. 

Por cierto, ya tengo python-dev instalado.

Además, instalando numpy vía

  sudo apt-get install python-numpy 

Tampoco funciona porque ya instalé numpy para Python 2.7 y el instalador responde que ya está actualizado.

¿Que puedo hacer? ¡Gracias!

No has instalado el paquete de desarrollo de Python 3. Instala python3.4-dev :

 apt-get install python3.4-dev 

El paquete principal nunca incluye los encabezados de desarrollo; La política del paquete Debian (y por extensión Ubuntu) es colocarlos en un paquete -dev separado. Para instalar numpy , sin embargo, necesita estos archivos para poder comstackr la extensión.