La distribución ‘pip == 7.1.0’ no se encontró y es requerida por la aplicación

Tengo la última versión de pip 8.1.1 en mi ubuntu 16. Pero no puedo instalar ningún módulo a través de pip porque recibo este error todo el tiempo.

File "/usr/local/bin/pip", line 5, in  from pkg_resources import load_entry_point File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2927, in  @_call_aside File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2913, in _call_aside f(*args, **kwargs) File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2940, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 635, in _build_master ws.require(__requires__) File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 943, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 829, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'pip==7.1.0' distribution was not found and is required by the application 

Encontré un enlace similar, pero no útil.

Yo reparé el mío esto con comando:

pip de instalación fácil

Tuve este problema durante mucho tiempo hasta que recientemente encontré que mi archivo ‘pip’ (/ usr / local / bin / pip) está intentando cargar la versión incorrecta de pip. Creo que también tiene 8.1.1 instalado correctamente en su máquina y puede intentarlo después de intentarlo.

  1. Abra su archivo / usr / local / bin / pip. Para mi se ve como:

     __requires__ = 'pip==9.0.1' import sys from pkg_resources import load_entry_point if __name__ == '__main__': sys.exit( load_entry_point('pip==9.0.1', 'console_scripts', 'pip')() ) 
  2. Cambie ‘pip == 9.0.1’ en la línea 1 y la última línea a la versión que haya instalado en su sistema, por ejemplo, deberá cambiar 7.1.0 a 8.1.1.

Básicamente / usr / local / bin / pip es un archivo de entrada para cargar el módulo de la versión requerida de pip. De alguna manera, cuando estoy actualizando / cambiando la instalación de pip, este archivo no se actualiza, por lo que lo actualizo manualmente cada vez.

No logré que funcionara usando easy_install pip o actualizando el archivo de configuración de pip /usr/local/bin/pip .

En su lugar, eliminé pip e instalé la distribución requerida por el archivo conf:

Desinstalación de pip:

$ sudo apt purge python-pip o $ sudo yum remove python-pip

Reinstalar la distribución requerida de pip (cambiar la distribución en consecuencia):

$ sudo easy_install pip==9.0.3

Eliminar todas las cosas pip / pip3 en .local incluyendo los paquetes.

 sudo apt-get purge python-pip python3-pip 

Ahora elimina todos los archivos pip3 de local

 sudo rm -rf /usr/local/bin/pip3 

Puede verificar qué pip está instalado de otra manera. Ejecute debajo de uno para eliminar todo (No se preocupe)

 sudo rm -rf /usr/local/bin/pip3.* 

Usando pip y / o pip3, reinstale los paquetes Python necesarios.

 sudo apt-get install python-pip python3-pip 

Sólo relink para resolverlo. Encuentre qué python: ls -l /usr/local/bin/python

 ln -sf /usr/local/Cellar/python/2.7.12/Frameworks/Python.framework/Versions/2.7/bin/pip /usr/local/bin/pip 

O reinstale pip: https://pip.pypa.io/en/stable/installing/

si tiene 2 versiones de pip, por ejemplo /usr/lib/pip y /usr/local/lib/pip pertenece a python 2.6 y 2.7. puede eliminar /usr/lib/pip y hacer un enlace pip => / usr / local / lib / pip.

Después de actualizar de 18.0 a 18.1, recibí el mismo error. Reinstalar el progtwig (sin usar pip en sí) funcionó para mí:

 $ curl https://bootstrap.pypa.io/get-pip.py > get-pip.py $ sudo python get-pip.py