¿Cómo pip instalar la versión antigua de la biblioteca (tensorflow)?

Estoy tratando de instalar tensorflow r0.11. Lo intenté

pip install tensorflow==r0.11 pip install tensorflow<0.12 

Pero me sale este error

 Could not find a version that satisfies the requirement tensorflow==0.11.0 (from versions: 0.12.0rc0, 0.12.0rc1, 0.12.0, 0.12.1) No matching distribution found for tensorflow==0.11.0 

Supongo que pip ya no es compatible con versiones depricadas, ¿cómo puedo obtenerlo?

Yo tambien lo intenté

 pip install git+git://github.com/tensorflow/tensorflow@r0.11 Cloning git://github.com/tensorflow/tensorflow (to r0.11) to /private/var/folders/1p/7km73m0s2cvdfb1js3ct8_mh0000gn/T/pip-JMMIRP-build Complete output from command python setup.py egg_info: Traceback (most recent call last): File "", line 1, in  IOError: [Errno 2] No such file or directory: '/private/var/folders/1p/7km73m0s2cvdfb1js3ct8_mh0000gn/T/pip-JMMIRP-build/setup.py' ---------------------------------------- Command "python setup.py egg_info" failed with error code 1 in /private/var/folders/1p/7km73m0s2cvdfb1js3ct8_mh0000gn/T/pip-JMMIRP-build/ 

Puede instalar la rueda pip desde una URL directamente, por ejemplo:

 # Ubuntu/Linux 64-bit, CPU only, Python 2.7 export TF_BINARY_URL=https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.11.0-cp27-none-linux_x86_64.whl pip install --ignore-installed --upgrade $TF_BINARY_URL 

En general, las instrucciones de instalación para versiones anteriores de TensorFlow se pueden encontrar en https://www.tensorflow.org/versions/r/get_started/os_setup . Por ejemplo, las instrucciones de instalación para TensorFlow 0.12 se pueden encontrar en: https://www.tensorflow.org/versions/r0.12/get_started/os_setup#using_pip .

Esto me funciona en Mac OS 10.13.1.

 pip install --user install tensorflow==1.3.0. 

Si desea instalar tensorflow r0.11 , significa que desea instalar las fonts desde una twig determinada ( r0.11 ). Por lo tanto, debe seguir las instrucciones de instalación oficiales de tensorflow: https://www.tensorflow.org/install/install_sources :

En caso de que desee instalar una versión “normal”. entonces puedes usar fácilmente el siguiente comando:

 pip install --upgrade tensorflow==1.3.0. 

Si tiene su propia biblioteca / paquete en github / gitlab, etc., debe agregar una etiqueta para comprometerse con una versión concreta de la biblioteca, por ejemplo v2.0, entonces puede instalar su paquete

 pip install git+ssh://link/name/repo.git@v2.0 

Esto funcionó para mí:

pip3 install 'tensorflow==1.2.0' --force-reinstall