Error al instalar scrapy en python 3.5

Estoy instalando Scrapy en Python 3.5. Me refiero a la guía de instalación aquí .

He instalado pip y conda . Intenté ambas maneras mencionadas en la guía, pero recibo este error:

error al instalar scrapy

Ya he instalado pip y minoconda :

 conda install -c scrapinghub scrapy 

y

  pip install Scrapy 

¿Qué hay de malo en la instalación?

Estás tratando de instalar scrapy en el intérprete de python, debes instalar el paquete en tu terminal. Además, un requisito para instalar scrapy es python 2.7, estás usando python 3.5


Actualizar:

Buenas noticias: Python 3 está llegando a Scrapy , puedes probar pip install scrapy==1.1.0rc1 ahora. Tenga en cuenta que todavía hay algunas limitaciones, pero que no pasará mucho tiempo para que scrapy tenga soporte completo para 3.x. Preste mucha atención al desarrollo de scrapy 😉

Scrapy no funciona con Python 3. En este momento, scrapy solo funciona con Python 2.7.

Antes de instalar Scrapy en Python 3.5 en Windows 10 en virtualenv Instale lxml, PyDispatcher luego se instala el código Scrapy de Simpy.

  (pymote_env) C:\Users\DDSHARMA\Documents\pymote_env>pip install PyDispatcher Collecting PyDispatcher Installing collected packages: PyDispatcher Successfully installed PyDispatcher-2.0.5 (pymote_env) C:\Users\DDSHARMA\Documents\pymote_env>pip install Scrapy Collecting Scrapy Using cached Scrapy-1.2.1-py2.py3-none-any.whl Requirement already satisfied (use --upgrade to upgrade): six>=1.5.2 in c:\users\ddsharma\documents\pymote_env\lib\site-packages (from Scrapy) Collecting service-identity (from Scrapy) Using cached service_identity-16.0.0-py2.py3-none-any.whl Collecting Twisted>=10.0.0 (from Scrapy) Using cached Twisted-16.4.1.tar.bz2 Collecting parsel>=0.9.3 (from Scrapy) Using cached parsel-1.0.3-py2.py3-none-any.whl Collecting pyOpenSSL (from Scrapy) Using cached pyOpenSSL-16.2.0-py2.py3-none-any.whl Requirement already satisfied (use --upgrade to upgrade): PyDispatcher>=2.0.5 in c:\users\ddsharma\documents\pymote_env\lib\site-packages (from Scrapy) Requirement already satisfied (use --upgrade to upgrade): lxml in c:\users\ddsharma\documents\pymote_env\lib\site-packages (from Scrapy) Collecting queuelib (from Scrapy) Using cached queuelib-1.4.2-py2.py3-none-any.whl Collecting w3lib>=1.15.0 (from Scrapy) Using cached w3lib-1.15.0-py2.py3-none-any.whl Collecting cssselect>=0.9 (from Scrapy) Using cached cssselect-1.0.0-py2.py3-none-any.whl Collecting pyasn1-modules (from service-identity->Scrapy) Using cached pyasn1_modules-0.0.8-py2.py3-none-any.whl Collecting pyasn1 (from service-identity->Scrapy) Using cached pyasn1-0.1.9-py2.py3-none-any.whl Collecting attrs (from service-identity->Scrapy) Using cached attrs-16.2.0-py2.py3-none-any.whl Collecting zope.interface>=4.0.2 (from Twisted>=10.0.0->Scrapy) Using cached zope.interface-4.3.2-cp35-cp35m-win32.whl Collecting cryptography>=1.3.4 (from pyOpenSSL->Scrapy) Using cached cryptography-1.5.2-cp35-cp35m-win32.whl Requirement already satisfied (use --upgrade to upgrade): setuptools in c:\users\ddsharma\documents\pymote_env\lib\site-packages (from zope.interface>=4.0.2->Twisted>=10.0.0->Scrapy) Collecting idna>=2.0 (from cryptography>=1.3.4->pyOpenSSL->Scrapy) Using cached idna-2.1-py2.py3-none-any.whl Collecting cffi>=1.4.1 (from cryptography>=1.3.4->pyOpenSSL->Scrapy) Using cached cffi-1.8.3-cp35-cp35m-win32.whl Collecting pycparser (from cffi>=1.4.1->cryptography>=1.3.4->pyOpenSSL->Scrapy) Downloading pycparser-2.16.tar.gz (230kB) 100% |################################| 235kB 286kB/s Building wheels for collected packages: Twisted, pycparser Running setup.py bdist_wheel for Twisted ... done Stored in directory: C:\Users\DDSHARMA\AppData\Local\pip\Cache\wheels\0e\53\62\e7b4cea7df9113fb2818b224eb5d143be981568d9c43057a0a Running setup.py bdist_wheel for pycparser ... done Stored in directory: C:\Users\DDSHARMA\AppData\Local\pip\Cache\wheels\34\cc\b5\34e805b130a9227f0681d5517cf554d950bb0361c3a373496f Successfully built Twisted pycparser Installing collected packages: pyasn1, pyasn1-modules, idna, pycparser, cffi, cryptography, pyOpenSSL, attrs, service-identity, zope.interface, Twisted, w3lib, cssselect, parsel, queuelib, Scrapy Successfully installed Scrapy-1.2.1 Twisted-16.4.1 attrs-16.2.0 cffi-1.8.3 cryptography-1.5.2 cssselect-1.0.0 idna-2.1 parsel-1.0.3 pyOpenSSL-16.2.0 pyasn1-0.1.9 pyasn1-modules-0.0.8 pycparser-2.16 queuelib-1.4.2 service-identity-16.0.0 w3lib-1.15.0 zope.interface-4.3.2 (pymote_env) C:\Users\DDSHARMA\Documents\pymote_env> 

Puedes instalar pipy en python 3.5+, solo debes instalar todas las dependencias primero, desde aquí https://docs.scrapy.org/en/latest/intro/install.html

  • pip instalar lxml
  • pip instalar parsel
  • pip instalar w3lib
  • instalación de la pipa torcida
  • pip instalar criptografía
  • pip instalar criptografía
  • pip instalar pyOpenSSL

y finalmente

  • pip instalar scrapy – funcionó para mí

Pude instalar scrapy en Python 3.5.

  1. Compruebe si puede instalar estos Twisted, lxml y pyOpenSSL.

  2. En mi caso tengo error al instalar lxml. Lo arreglé descargando lxml‑3.6.4‑cp35‑cp35m‑win_amd64.whl desde http://www.lfd.uci.edu/~gohlke/pythonlibs/#lxml en función de su versión de Python y Windows. (Gracias a la generosidad de Christoph Gohlke por compartir esta biblioteca). Lo instalé usando el siguiente comando:


 pip install lxml‑3.6.4‑cp35‑cp35m‑win_amd64.whl