Importar error al instalar periódico

Soy bastante nuevo en Python y estoy tratando de importar un periódico para la extracción de artículos. Cada vez que bash importar el módulo, obtengo ImportError: cannot import name images . ¿Alguien ha encontrado este problema y ha encontrado una solución?

Pude solucionar este problema creando un directorio de images en /usr/local/lib/python2.7/dist-packages/newspaper , moviendo images.py a este directorio y colocando un __init__.py en blanco en este directorio.

Sé que esta es una entrada fechada, pero para cualquier otra persona que enfrentó el mismo problema que yo, al principio intenté resolver este problema. Cuando ejecuté el primer import newspaper , me enfrenté a este error. lxml runtime error: Reason: Incompatible library version: etree.so requires version 12.0.0 or later, but libxml2.2.dylib provides version 10.0.0

Cuando intenté volver a ejecutar mi código (sin corregir nada), obtuve el error encontrado en este artículo. No tengo idea de por qué este fue el caso, y no pude resolver mi problema usando el método anterior (no funcionó para mí, pero aún podría funcionar para usted). Si alguien estaba buscando a tientas como yo en Jupyter para que el newspaper funcione, considere el siguiente enlace. Espero que esto sea de ayuda.

https://stackoverflow.com/a/31607751/6143792