¿Cómo instalar scikit-image?

Su descarga de scikit-imagen dice:

pip install -U scikit-image 

o

 easy_install -U scikit-image 

pero ambos fallan, independientemente de la bandera U, como se muestra a continuación:

 Georgioss-MacBook-Pro:Downloads gsamaras$ sudo pip install scikit-image The directory '/Users/gsamaras/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag. The directory '/Users/gsamaras/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag. Collecting scikit-image Downloading scikit_image-0.12.3-cp27-cp27m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (22.2MB) 100% |████████████████████████████████| 22.2MB 53kB/s Requirement already satisfied: dask[array]>=0.5.0 in /Library/Python/2.7/site-packages (from scikit-image) Collecting six>=1.7.3 (from scikit-image) Downloading six-1.10.0-py2.py3-none-any.whl Collecting networkx>=1.8 (from scikit-image) Downloading networkx-1.11-py2.py3-none-any.whl (1.3MB) 100% |████████████████████████████████| 1.3MB 133kB/s Requirement already satisfied: pillow>=2.1.0 in /Library/Python/2.7/site-packages (from scikit-image) Requirement already satisfied: numpy; extra == "array" in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (from dask[array]>=0.5.0->scikit-image) Requirement already satisfied: toolz>=0.7.2; extra == "array" in /Library/Python/2.7/site-packages (from dask[array]>=0.5.0->scikit-image) Collecting decorator>=3.4.0 (from networkx>=1.8->scikit-image) Downloading decorator-4.0.10-py2.py3-none-any.whl Installing collected packages: six, decorator, networkx, scikit-image Found existing installation: six 1.4.1 DEPRECATION: Uninstalling a distutils installed project (six) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will only partially uninstall the project. Uninstalling six-1.4.1: Exception: Traceback (most recent call last): File "/Library/Python/2.7/site-packages/pip-9.0.1-py2.7.egg/pip/basecommand.py", line 215, in main status = self.run(options, args) File "/Library/Python/2.7/site-packages/pip-9.0.1-py2.7.egg/pip/commands/install.py", line 342, in run prefix=options.prefix_path, File "/Library/Python/2.7/site-packages/pip-9.0.1-py2.7.egg/pip/req/req_set.py", line 778, in install requirement.uninstall(auto_confirm=True) File "/Library/Python/2.7/site-packages/pip-9.0.1-py2.7.egg/pip/req/req_install.py", line 754, in uninstall paths_to_remove.remove(auto_confirm) File "/Library/Python/2.7/site-packages/pip-9.0.1-py2.7.egg/pip/req/req_uninstall.py", line 115, in remove renames(path, new_path) File "/Library/Python/2.7/site-packages/pip-9.0.1-py2.7.egg/pip/utils/__init__.py", line 267, in renames shutil.move(old, new) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 302, in move copy2(src, real_dst) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 131, in copy2 copystat(src, dst) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 103, in copystat os.chflags(dst, st.st_flags) OSError: [Errno 1] Operation not permitted: '/tmp/pip-qlMJKP-uninstall/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/six-1.4.1-py2.7.egg-info' Georgioss-MacBook-Pro:Downloads gsamaras$ 

y:

 Georgioss-MacBook-Pro:Downloads gsamaras$ sudo easy_install scikit-image Searching for scikit-image Reading https://pypi.python.org/simple/scikit-image/ Best match: scikit-image 0.12.3 Downloading https://pypi.python.org/packages/86/d0/b0192dc9a544da90f2d9150bcd84b981c6873e42a1f752b6affb89180ad8/scikit-image-0.12.3.tar.gz#md5=04ea833383e0b6ad5f65da21292c25e1 Processing scikit-image-0.12.3.tar.gz Writing /tmp/easy_install-X6Pjoh/scikit-image-0.12.3/setup.cfg Running scikit-image-0.12.3/setup.py -q bdist_egg --dist-dir /tmp/easy_install-X6Pjoh/scikit-image-0.12.3/egg-dist-tmp-lHJxkL Killed: 9 

Fíjate que la brew también falla, no puede encontrarla.

Tengo Python 2.7.10, Matplotlib 1.3.1, PIL 3.4.2 y Scipy ‘0.18.1’. ¿Qué hacer?

En general, es una mala idea instalar bibliotecas en Python para todo el sistema. Utilice un virtualenv para cada proyecto en su lugar.

Primero instale virtualenv globalmente en su Mac:

 $ [sudo] pip install virtualenv 

Luego use el comando virtualenv para crear un nuevo (una copia) del ejecutable de Python:

 $ cd your/prefred/folder $ virtualenv your_project 

Activar el virtualenv :

 $ source your_project/bin/activate 

Su virtualenv se crea y se activa (la solicitud se cambia para mostrar la activación). Puedes instalar cualquier cosa en él:

 $ pip install -U scikit-image