Instalar una versión particular con easy_install

Estoy tratando de instalar lxml . He echado un vistazo al sitio web y la versión 2.2.8 me pareció razonable, pero cuando hice easy_install lxml , instalé la versión 2.3.beta1, que no es lo que realmente quiero, supongo.

¿Cuál es la mejor manera de solucionar esto y cómo puedo forzar a easy_install a instalar una versión en particular?

(Mac os x 10.6)

Creo que la forma de especificar una versión sería así:

 easy_install lxml==2.2.8 

Yo (y la mayoría de los otros usuarios de Python que sospecho) dejé de usar easy_install y comencé a usar pip algún tiempo, por lo que una solución en esos términos es:

 easy_install pip pip install lxml==2.2.8 

( pip tiene varios beneficios, incluyendo un comando de uninstall )

De la documentación de easy_install:

easy_install PackageName==1.2.3

Deberías hacer algo como esto:

 easy_install "lxml==2.2.8"