Versión Anaconda con Python 3.5.

Quiero instalar tensorflow con python 3.5 usando anaconda pero no sé qué versión de anaconda tiene python 3.5. Cuando voy a la página de descarga de anaconda, aparece Anaconda 4.3.1, que tiene una versión 3.6 o 2.7 de python.

Puede instalar cualquier versión actual de Anaconda. A continuación, puede crear un entorno conda con sus necesidades particulares a partir de la documentación.

 conda create -n tensorflowproject python=3.5 tensorflow ipython 

Este comando tiene una versión específica para Python y cuando este entorno tensorflowproject se actualice, se actualizará a Python 3.5999999999 pero nunca pasará a 3.6. Luego cambias a tu entorno usando cualquiera

 source activate tensorflowproject 

para linux / mac o

 activate tensorflowproject 

en las ventanas

Según este anuncio , Anaconda actualizó a Python 3.6 a partir de la versión 4.3, así que … es probable que desee el paquete 4.2.0 del archivo del instalador .

Según el documento oficial, se recomienda degradar todo el entorno Python:

 conda install python=3.5 

Anacoda3-4.2.0 Usa python 3.5 Puede encontrar lo mismo en el enlace que se encuentra a continuación: https://repo.continuum.io/archive/Anaconda3-4.2.0-Windows-x86_64.exe

Me enfrenté al mismo problema y encontré la versión correcta al revisar las distribuciones de Anaconda 4.2.0 disponibles en el archivo del instalador aquí

comando instalar:

  • python3.5: conda install python=3.5
  • python3.6: conda install python=3.6

descarga el instalador Anaconda más reciente:

  • python3.5: Anaconda 4.2.0
  • python3.6: Anaconda 5.2.0

referencia de anaconda doc:

  • ¿Cómo consigo Anaconda con Python 3.5 o 3.6?

Para resaltar algunos puntos:

Los documentos recomiendan el uso de un entorno de instalación: https://conda.io/docs/user-guide/install/download.html#choosing-a-version-of-anaconda-or-miniconda

El archivo de la versión está aquí: https://repo.continuum.io/archive/

El historial de versiones está aquí: https://docs.anaconda.com/anaconda/release-notes

“Anaconda3 entonces su python 3.x y si es Anaconda2 entonces su 2.x” – +1 papbiceps

El archivo de versión está ordenado como el más nuevo en la parte superior, pero Anaconda2 ABOVE Anaconda3.