AttributeError: el módulo Pip no tiene ningún atributo ‘main’

Estoy tratando de construir la api de python para un proyecto de código abierto llamado Zulip y me mantengo en el mismo problema como se indica en la captura de pantalla a continuación.

Estoy ejecutando python3 y mi versión pip es 10.0.0. El archivo en cuestión es setup.py y el código que se pip.main() es cuando se accede al atributo pip.main() para instalar un paquete.

Ahora, sé que esta comstackción debería tener éxito porque es un proyecto de código abierto, pero he intentado durante horas solucionar el problema de dependencia con respecto a pip.main() .

Cualquier ayuda sería muy apreciada.

introduzca la descripción de la imagen aquí

 python3 -m pip install --user --upgrade pip==9.0.3 

problema pip: rollback

Primer bash

 import pip pip.__version__ 

Si el resultado es ’10 .0.0 ‘, significa que instaló pip correctamente
ya que pip 10.0.0 ya no es compatible con pip.main (), puede que le resulte útil.
https://pip.pypa.io/en/latest/user_guide/#using-pip-from-your-program
Use algo como import subprocess subprocess.check_call(["python", '-m', 'pip', 'install', 'pkg']) # install pkg subprocess.check_call(["python", '-m', 'pip', 'install',"--upgrade", 'pkg']) # upgrade pkg


Edición: pip 10.0.1 todavía no soporta main
Puede elegir DESCARGAR su versión pip mediante el siguiente comando:
python -m pip install --upgrade pip==9.0.3

Parece que pip hizo un refactor y movió main a interno. Hay una discusión completa al respecto aquí: https://github.com/pypa/pip/issues/5240

Una solución para mí era cambiar

 import pip pip.main(...) 

a

 from pip._internal import main main(...) 

Recomiendo leer la discusión, no estoy seguro de que este sea el mejor enfoque, pero funcionó para mis propósitos.

Para verificar si es su problema de instalación de pip , intente usar easy_install para instalar una versión anterior de pip:

 easy_install pip==9.0.1 

Si esto tiene éxito, pip debería estar trabajando ahora. Luego, puede seguir adelante para instalar cualquier otra versión de pip que desee con:

 pip install pip==10.... 

O simplemente puede quedarse con la version 9.0.1 , ya que su proyecto requiere una versión> = 9.0.

Intenta construir tu proyecto de nuevo.

Esto me ayuda, https://pip.pypa.io/en/stable/installing/

 curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py python get-pip.py 

Si está usando python3 y no lo configura por defecto. hacer esto,

 python3 get-pip.py 

Esto funciona para mi.

Si la instalación de python -m pip install --upgrade pip==9.0.3 no funciona, y está usando Windows,

  1. Vaya a este directorio y mueva las carpetas pip a otro lugar.

introduzca la descripción de la imagen aquí

  1. Cierra tu IDE si lo tienes abierto.

  2. Presiona ‘Reparar’ en Python 3.

introduzca la descripción de la imagen aquí

  1. Su IDE debe dejar de detectar paquetes pip y solicitarle que los instale. Instala y guarda la última versión estable de pip mediante el locking de actualizaciones automáticas. introduzca la descripción de la imagen aquí

Pip 10.0. * No soporta main.

Tienes que bajar de categoría a pip 9.0.3.

Mi solución es verificar el número de versión de pip y usar la función principal correcta de importación correcta

  import pip if int(pip.__version__.split('.')[0])>9: from pip._internal import main else: from pip import main def install(package): main(['install', package]) 

Funciona bien:

  py -m pip install --user --upgrade pip==9.0.3 

Edite el archivo: C: \ Users \ kpate \ hw6 \ python-zulip-api \ zulip_bots \ setup.py en la línea 108

a

 rcode = pip.main(['install', '-r', req_path, '--quiet']) 

hacer

 rcode = getattr(pip, '_main', pip.main)(['install', '-r', req_path, '--quiet'])´ 

No estoy seguro acerca de Windows. Pero para usuarios de mac, usa esto:

 pip install --upgrade pip==9.0.3 

Paso 1 curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py Paso2 python get-pip.py

Solucioné este problema actualizando a la última versión.

 sudo pip install --upgrade pip 

Mi versión: pip 18.1 de /Library/Python/2.7/site-packages/pip (python 2.7)

Me enfrenté al mismo error al usar pip en anaconda3 4.4.0 (python 3.6) en windows.

Arreglé el problema con el siguiente comando:

 easy_install pip==18.* ### installing the latest version pip 

O si se requiere una versión inferior de pip, mencione lo mismo en el comando.

O puede intentar instalar la versión inferior y luego actualizarla de la siguiente manera:

 easy_install pip==9.0.1 easy_install --upgrade pip