“Falló con el código de error 1” al instalar scipy

Tengo Python 2.7.9 en Windows 7 de 64 bits. Estoy tratando de instalar scipy usando pip. pip install scipy pero obtengo el siguiente error:

 Command "C:\Python27\python.exe -c "import setuptools, tokenize;__file__='c:\\us ers\\admin\\appdata\\local\\temp\\pip-build-xpl5cw\\scipy\\setup.py';exec(compil e(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file __, 'exec'))" install --record c:\users\admin\appdata\local\temp\pip-b68pfc-reco rd\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in c:\users\admin\appdata\local\temp\pip-build-xpl5cw\scipy 

Busqué en google y stackoverflow soluciones, pero nada funcionó. Intenté actualizar pip y tampoco funcionó.

Aquí están mis paquetes instalados y sus versiones:

 httplib2 (0.9.1) nltk (3.0.3) nose (1.3.7) numpy (1.9.2) pip (7.0.3) pytz (2015.4) scikit-learn (0.16.1) setuptools (17.1.1) six (1.9.0) twilio (4.4.0) wheel (0.24.0) 

En Windows, deberá utilizar los binarios precomstackdos no oficiales:

http://www.lfd.uci.edu/~gohlke/pythonlibs/

Seleccione la versión que coincida con su architecture y la versión de Python.

Estoy en Ubuntu 14.04. Intenté realizar la instalación a través de pip, que siguió fallando con el código de error 1 o tardé una eternidad en finalizar (¡en realidad nunca terminé!). Sin embargo, el siguiente comando funcionó sin problemas:

 sudo apt-get install python-numpy python-scipy python-matplotlib ipython ipython-notebook python-pandas python-sympy python-nose 

Referencia: http://www.scipy.org/install.html

También tuve el mismo error al instalar scipy .

Luego descargué e instalé MiniConda . Y luego usé el siguiente comando para instalar pytables.

 conda install -c conda-forge scipy 

Por favor, consulte la siguiente captura de pantalla.

introduzca la descripción de la imagen aquí

Instalar setuptools lo hizo funcionar para mí (Mac OS)

 pip install -U pip setuptools