Python actualizado en Snowleopard El uso de Homebrew ahora pip y easy_install no funcionan

Soy nuevo en Python, he cambiado mi ruta para apuntar a la nueva Python 2.7, pero pip y easy_install, y mercurial todavía están buscando la versión 2.6 instalada por defecto. ¿Cómo puedo solucionar esto?

Debe volver a instalar easy_install utilizando Python 2.7 y todos los demás módulos también. No espere que los paquetes existentes instalados con un intérprete diferente deban funcionar fuera de la caja con un intérprete nuevo. Reinstalar en el nuevo intérprete de Python 2.7 es el camino a seguir. Primer paso: reinstale easy_install descargando ez_setup.py (Google) y ejecutándolo con el intérprete 2.7.

setuptools instalar pip y setuptools nuevamente (lo que proporciona el comando easy_install ) para su nueva versión de Python. pip y setuptools no se instalan globalmente, sino que deben instalarse específicamente para cada versión de Python en su sistema.

Para instalar pip :

 $ curl -O https://github.com/pypa/pip/raw/master/contrib/get-pip.py $ python get-pip.py 

Para instalar setuptools :

 $ curl -O http://peak.telecommunity.com/dist/ez_setup.py $ python ez_setup.py 

… pero probablemente deberías usar Distribuir (es una versión más reciente de setuptools ):

 $ curl -O http://python-distribute.org/distribute_setup.py $ python distribute_setup.py