Spyder anaconda se bloquea en Linux con falla de segmentación

Acabo de instalar Anaconda en Linux. Cuando se intenta abrir spyder (ya sea desde el navegador o la terminal), no funciona. Recibo el siguiente error cuando bash abrirlo en el terminal:

Fallo de segmentación (núcleo volcado)

Actualicé a Conda completamente pero no puedo resolver el problema. Estoy usando Conda versión 4.5.5 y Ubuntu 18.04. ¿Alguna idea?

Related of "Spyder anaconda se bloquea en Linux con falla de segmentación"

(El mantenedor de Spyder aquí ) Este problema se debe a controladores de tarjetas gráficas defectuosos y hay dos formas de solucionarlo:

  1. Actualización a Spyder 3.3 o superior.
  2. Instalar pyopengl con conda.

Según mis experiencias, si tiene ubuntu 18.04, anaconda 4.5 o superior y spyder 3.3 o superior, la instalación de pyopengl no funciona, ya que spyder 3.3 debería manejarlo. Como se recomendó anteriormente, antes de comenzar a arreglarlo, intente actualizar el spyder primero:

 conda update spyder 

luego bajar Qt :

 conda install pyqt=5.6 

Probablemente debería solucionar su problema. Otras soluciones se pueden encontrar aquí:

Solución de problemas de Spyder, guía y preguntas frecuentes

tanto como :

Solución de problemas básicos y RCP de emergencia

Vi un problema en el nuevo Fedora con una nueva instalación de anaconda. Solo actualizando el spyder a la última versión (en mi caso 3.3.1) lo arreglé, sin nada más.

(Por cierto: puedes hacerlo incluso desde el navegador de anaconda, solo cuida la rueda dentro de cada panel de aplicación en la esquina derecha).

Recomendaría arreglar cualquier cosa paso a paso, comenzar con la actualización al último spyder y si esto no funciona, intente las otras cosas.

Las soluciones por aquí no funcionaron para mí. He desinstalado Anaconda https://docs.anaconda.com/anaconda/install/uninstall/ y lo reinstalé https://docs.anaconda.com/anaconda/install/linux/

Sólo entonces desapareció la falla de segmentación.

Tenga en cuenta que esto ha funcionado con Ubuntu 14.04 LTS (una versión anterior en el momento de escribir este artículo) y Anaconda3 5.3.0 con Spyder 3.3.1 (la última versión); versiones verificadas con la conda list . La versión de Spyder compatible con Ubuntu 14 aún es 2.5.5, por lo que este arreglo me permite tener a bordo un nuevo Spyder sin actualizar la distro. Sin mencionar que, según se informa, los desarrolladores prefieren mantener a Spyder en el entorno de Anaconda en lugar de en otros lugares.