ImportError: no hay un módulo llamado sklearn.feature_extraction.text

Utilizo desde python 2.7 y el gestor de paquetes pacman , e instalo sclearn con él. pero cuando tengo un ImportError:

 >>> from sklearn.feature_extraction.text import TfidfVectorizer Traceback (most recent call last): File "", line 1, in  ImportError: No module named sklearn.feature_extraction.text 

¿Cómo puedo solucionar este error?

Para Python 2, debería poder usar este comando para instalar usando pacman:

pacman -S python2-scikit-learn

Asegúrese de que el nombre del paquete tenga el número “2”.

Según la guía de instalación de scikit-learn , otra forma de instalarla es usando pip:

pip instalar –user –install-option = “- prefix =” -U scikit-learn

Al instalar en Ubuntu Linux, primero tiene que instalar dependencias usando apt-get, luego use una instalación pip, de lo contrario la instalación pip normal de scikit-learn no funcionará correctamente. Vea abajo:

Paso 1: Asegúrate de que apt-get esté actualizado
sudo apt-get update

Paso 2: instalar dependencias
sudo apt-get instalar build-essential python-dev python-setuptools python-numpy python-scipy libatlas-dev libatlas3gf-base

Paso 3: pip instala Scikit Learn
pip instalar –user –install-option = “- prefix =” -U scikit-learn

¡Espero que esto ayude!

  1. Instalar python 2.7 desde la página de inicio de python
    • Instalé 2.7.14 (más tardar el 22/07/2018)
  2. PIP está disponible de forma predeterminada en C: \ Python27 \ scripts. Se agregaron estas ubicaciones (C: \ Python27 \ & C: \ Python27 \ scripts) a la variable de ruta del sistema (máquina con Windows10)
  3. Instalar el paquete scikit-learn

    pip instalar -U scikit-learn

Podemos ver la biblioteca del paquete scikit learn en c: \ python27 \ lib \ site-packages C: \ Python27 \ Lib \ site-packages \ sklearn 4. Instale numpy y scipy ya que estos 2 son requisitos previos para scikit-learn

pip instalar numpy

pip instalar scipy

C: \ Python27 \ Lib \ site-packages \

Utilice este comando pip install -U scikit-learn