Mac OSX: los paquetes de Python no se pudieron comstackr debido a problemas con gcc

Estoy intentando instalar el paquete MySQL-python con el siguiente error:

 cc1: error: unrecognized command line option "-arch" cc1: error: unrecognized command line option "-Wno-long-double" error: Setup script exited with error: command 'gcc' failed with exit status 1 

Estoy usando la Mac OSX version 10.6.8 con gcc

 bash-3.2$ gcc --version gcc (GCC) 4.2.1 (Apple Inc. build 5666) (dot 3) 

¿Cómo puedo resolver este problema?

Gracias

gcc el gcc que viene con Mac y eliminé el primer error que es

 cc1: error: unrecognized command line option "-arch" 

para el segundo, eliminé la opción de /Library/Frameworks/Python.framework/Versions/Current/lib/python2.5/config/Makefile
desde BASECFLAGS y agregue lo siguiente a mi ~ / .bashrc

 export C_INCLUDE_PATH=/Developer/SDKs/MacOSX10.5.sdk/usr/include export LIBRARY_PATH=/Developer/SDKs/MacOSX10.5.sdk/usr/lib 

y eso eliminó el error

 cc1: error: unrecognized command line option "-Wno-long-double" 

Debe utilizar el gcc suministrado por Apple que viene con las Herramientas de desarrollo de Xcode. Debería haber una versión de Snowcode Leopard de Xcode que venía con su Mac o está en un DVD de restauración del sistema o una copia minorista de Snow Leopard o puede descargarse (después del registro gratuito) desde Apple Developer Connection.

Solución 1:

Puede faltar el paquete de instalación de pyton-dev :

 $ yum list | grep python-dev $ yum -y install python-dev* //need root privileges 

Después de la ejecución, reinstalación.

Solución 2:

Si la solución 1 no resuelve el problema, es posible que “gcc” no esté instalado o ya no esté en el PATH

 $ whereis gcc //check gcc $ echo $PATH //Check the gcc whether in the PATH 

Si no instala el “gcc”, ejecute el siguiente comando

 $ yum list | grep gcc $ sudo yum install -y gcc.x86_64 

Después de la ejecución, reinstalar.