Cómo actualizar spyder en anaconda.

Tengo instalado Anaconda (Python 2.7.11 | Anaconda personalizado (64 bits) | (predeterminado, 16 de febrero de 2016, 09:58:36) [MSC v.1500 64 bit (AMD64)] en win32) y estoy usando Spyder 2.3.8

Me gustaría actualizar Spyder a la última versión, así que revisé los comandos:

conda update conda conda update anaconda conda update spyder 

Todos se ejecutaron sin errores, pero la versión del spyder no cambió, este es el comando que estoy usando para iniciar:

C: \ Anaconda2 \ pythonw.exe C: \ Anaconda2 \ cwp.py C: \ Anaconda2 “C: /Anaconda2/pythonw.exe” “C: /Anaconda2/Scripts/spyder-script.py” –new-instance

¿Me estoy perdiendo de algo?

Gracias

Para ampliar el comentario de juanpa.arrivillaga :

Si desea actualizar Spyder en el entorno raíz, la conda update spyder funciona para mí.

Si desea actualizar Spyder para un entorno virtual que ha creado (por ejemplo, para una versión diferente de Python), entonces conda update -n $ENV_NAME spyder donde $ENV_NAME es el nombre de su entorno.

Veo que usaste pip para actualizar. Esto está muy desaconsejado (al menos en Spyder 3). Los avisos de actualización de Spyder que recibí siempre han incluido lo siguiente:

“NOTA IMPORTANTE: parece que está utilizando Spyder con Anaconda / Minconda. No use pip para actualizarlo, ya que esto probablemente interrumpirá su instalación. En lugar de eso, espere hasta que haya nuevos paquetes de Conda disponibles y use Conda para realizar la actualización. ”

Vaya a Anaconda Naviagator, busque spyder, haga clic en configuración en la esquina superior derecha de la aplicación spyder. Haga clic en la pestaña de actualización

Una forma de evitar errores durante la instalación o actualización de paquetes es ejecutar el indicador de Anaconda como Administrador. ¡Espero eso ayude!

Usando pip directamente:

ADVERTENCIA: Esto interrumpirá su instalación de Anaconda como lo describe el mantenedor de Spyder en los comentarios a continuación; puede probar esta solución solo si la solución mencionada anteriormente que utiliza Conda no funciona

pip instalar – actualizar spyder

Podría obtener un error una vez que inicie el nuevo Spyder “nbconvert> = 4.0: None (NOK)”, que requerirá que vuelva a instalar configparser:

conda desinstalar configparser

conda install configparser

Ahora debería tener una instalación nueva y actualizada de Spyder.