Se requiere Microsoft Visual C ++ 14.0. Consígalo con “Microsoft Visual C ++ Build Tools”: http: //landinghub.visualst udio.com/visual-cpp-build-tools

He intentado todos los métodos mencionados en internet pero no sirve de nada. Estoy tratando de instalar misaka escribiendo pip install misaka que sigue quejándose mostrando el mismo mensaje. He descargado e instalado MS Build Tool 2015 y 2017, reinicié mi computadora portátil. Lo que sea que hice, no pude averiguar por qué se queja. Python versión 3.6.4 Windows 10

para resolver cualquiera de los siguientes errores. Se Failed building wheel for misaka error en la Failed building wheel for misaka o no se Failed to build misaka o se Failed to build misaka Microsoft Visual C++ 14.0 is required o Unable to find vcvarsall.bat

La solución es:

1- Vaya a: https://www.visualstudio.com/downloads/#build-tools-for-visual-studio-2017

2- Selecciona descarga gratuita bajo Visual Studio Community 2017.

(Esto descargará el instalador.) Ejecuta el instalador.

3- Ahora el paso más importante es seleccionar lo que necesita: en la pestaña de carga de trabajo:

a) en Windows solo hay 3 opciones CHECK Desktop development with C ++

b) bajo Web & Cloud hay 7 opciones solo CHECK Python development (creo que esto es opcional, pero lo he hecho).

4- ahora ve a tu cmd y escribe: pip3 instala misaka

Buena suerte Captura de pantalla de lo que necesitas instalar.

Tenga en cuenta que si ya instaló Visual Studio, cuando ejecute el instalador, puede modificar el suyo (haga clic en el botón Modificar en Visual Studio Community 2017) y siga los pasos 3 y 4. introduzca la descripción de la imagen aquí

Utilizar el instalador https://visualstudio.microsoft.com/visual-cpp-build-tools/ y seleccionar solo cuatro componentes específicos ayudó a resolver el error.

Construir herramientas de selección para spacy.

Recibía el mismo error al intentar instalar biopython con Python 3.7 en Windows 10.

Instalar solo las herramientas de comstackción (en lugar de la edición completa de la comunidad como se sugiere en la otra respuesta), con las opciones “Compatibilidad con C ++ / CLI” y “VC ++ 2015.3 v14.00 (v140) para el escritorio” activadas además de los valores predeterminados, resuelve el problema.