pkg_resources.DistributionNotFound: la distribución ‘pip == 1.5.4’ no se encontró y es requerida por la aplicación

Trabajando en Ubuntu y python 2.7.6. cuando bash usar pip, solo pip seguido de enter,

File "/usr/local/bin/pip", line 5, in  from pkg_resources import load_entry_point File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 3095, in  File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 3081, in _call_aside File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 3108, in _initialize_master_working_set File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 660, in _build_master File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 673, in _build_from_requirements File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 846, in resolve pkg_resources.DistributionNotFound: The 'pip==1.5.4' distribution was not found and is required by the application 

Actualizado para 2017 (Ubuntu 17)

 sudo apt-get purge python-pip wget https://bootstrap.pypa.io/get-pip.py sudo python get-pip.py pip --version rm get-pip.py 

Enfrentó el mismo problema con ubuntu 14.04, python2.7.6 y pip 1.5.4. Hice esto,

  sudo apt-get install --reinstall python2.7 

Para reinstalar python (aunque no es necesario)

  sudo apt-get purge python-pip 

(removiendo python pip)

  wget https://raw.github.com/pypa/pip/master/contrib/get-pip.py 

(descargue de esto, esta es la versión actualizada (9))

  sudo python get-pip.py sudo pip install package-name 

¡Esto funcionó!