¿Django-haystack 2.6.1 es compatible con Django 2.0?

Mi pregunta es simple (según el título). ¿El Django-haystack actual es compatible con el Django 2.0 más nuevo? ¿Alguien está usando esta combinación?

Los requisitos en los documentos y en PYPI sugieren que es:

  • https://django-haystack.readthedocs.io/en/master/#requirements
  • https://pypi.python.org/pypi/django-haystack/2.6.1

Pero el siguiente usuario enfrenta problemas tan bien como yo cuando bash usarlo con Django 2.0:

  • Pajar de Django 2.0 whoosh índice de actualización, reconstruir error de lanzamiento de índice

La misma configuración funciona con Django 1.11.

¡Gracias!

Haystack 2.6.1 no es compatible con Django 2.0. El README dijo una versión compatible de Django pero no especificó explícitamente las versiones compatibles. Si observa el setup.py , las setup.py contienen 'Django>=1.8,<1.12'.

El soporte para Django 2.0 se agregó en Haystack 2.8, que se lanzó en marzo de 2018.