Tratando de instalar cualquier cosa con pip en macos y no puedo

Creo que tengo un problema con mi sistema mac os. Todo lo que trato de instalar en él usando pip, obtengo los mismos errores una y otra vez, solo pegué las líneas que muestran un error para no saturar este hilo:

Collecting murmurhash3 Using cached https://files.pythonhosted.org/packages/b5/f4/1f9c4851667a2541bd151b8d9efef707495816274fada365fa6a31085a32/murmurhash3-2.3.5.tar.gz Building wheels for collected packages: murmurhash3 Running setup.py bdist_wheel for murmurhash3 ... error Complete output from command /usr/local/opt/python/bin/python3.7 -u -c "import setuptools, tokenize;__file__='/private/var/folders/15/_mc1281d6kn_z8my6cz6dj740000gq/T/pip-install-_4hr8w03/murmurhash3/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /private/var/folders/15/_mc1281d6kn_z8my6cz6dj740000gq/T/pip-wheel-k28wu_2e --python-tag cp37: running bdist_wheel running build running build_ext building 'mmh3' extension creating build creating build/temp.macosx-10.14-x86_64-3.7 clang -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -I/usr/include -I/Applications/Xcode-beta.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/System/Library/Frameworks/Tk.framework/Versions/8.5/Headers -I/usr/local/include -I/usr/local/opt/openssl/include -I/usr/local/opt/sqlite/include -I/usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/include/python3.7m -c mmh3module.cpp -o build/temp.macosx-10.14-x86_64-3.7/mmh3module.o In file included from mmh3module.cpp:3: /usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/include/python3.7m/Python.h:14:2: error: "Something's broken. UCHAR_MAX should be defined in limits.h." #error "Something's broken. UCHAR_MAX should be defined in limits.h." ^ /usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/include/python3.7m/Python.h:18:2: error: "Python's source code assumes C's unsigned char is an 8-bit type." #error "Python's source code assumes C's unsigned char is an 8-bit type." ^ mmh3module.cpp:99:5: error: use of undeclared identifier 'memcpy'; did you mean 'wmemcpy'? memcpy(bytes, result, 16); ^~~~~~ wmemcpy /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/usr/include/wchar.h:152:10: note: 'wmemcpy' declared here wchar_t *wmemcpy(wchar_t * __restrict, const wchar_t * __restrict, size_t); ^ mmh3module.cpp:99:12: error: cannot initialize a parameter of type 'wchar_t *' with an lvalue of type 'char [16]' memcpy(bytes, result, 16); ^~~~~ /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/usr/include/wchar.h:152:38: note: passing argument to parameter here wchar_t *wmemcpy(wchar_t * __restrict, const wchar_t * __restrict, size_t); ^ 4 errors generated. error: command 'clang' failed with exit status 1 ---------------------------------------- Failed building wheel for murmurhash3 Running setup.py clean for murmurhash3 Failed to build murmurhash3 Installing collected packages: murmurhash3 Running setup.py install for murmurhash3 ... error Complete output from command /usr/local/opt/python/bin/python3.7 -u -c "import setuptools, tokenize;__file__='/private/var/folders/15/_mc1281d6kn_z8my6cz6dj740000gq/T/pip-install-_4hr8w03/murmurhash3/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /private/var/folders/15/_mc1281d6kn_z8my6cz6dj740000gq/T/pip-record-7a15nstl/install-record.txt --single-version-externally-managed --compile: running install running build running build_ext building 'mmh3' extension creating build creating build/temp.macosx-10.14-x86_64-3.7 clang -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -I/usr/include -I/Applications/Xcode-beta.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/System/Library/Frameworks/Tk.framework/Versions/8.5/Headers -I/usr/local/include -I/usr/local/opt/openssl/include -I/usr/local/opt/sqlite/include -I/usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/include/python3.7m -c mmh3module.cpp -o build/temp.macosx-10.14-x86_64-3.7/mmh3module.o In file included from mmh3module.cpp:3: /usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/include/python3.7m/Python.h:14:2: error: "Something's broken. UCHAR_MAX should be defined in limits.h." #error "Something's broken. UCHAR_MAX should be defined in limits.h." ^ /usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/include/python3.7m/Python.h:18:2: error: "Python's source code assumes C's unsigned char is an 8-bit type." #error "Python's source code assumes C's unsigned char is an 8-bit type." ^ mmh3module.cpp:99:5: error: use of undeclared identifier 'memcpy'; did you mean 'wmemcpy'? memcpy(bytes, result, 16); ^~~~~~ wmemcpy /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/usr/include/wchar.h:152:10: note: 'wmemcpy' declared here wchar_t *wmemcpy(wchar_t * __restrict, const wchar_t * __restrict, size_t); ^ mmh3module.cpp:99:12: error: cannot initialize a parameter of type 'wchar_t *' with an lvalue of type 'char [16]' memcpy(bytes, result, 16); ^~~~~ /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/usr/include/wchar.h:152:38: note: passing argument to parameter here wchar_t *wmemcpy(wchar_t * __restrict, const wchar_t * __restrict, size_t); ^ 4 errors generated. error: command 'clang' failed with exit status 1 ---------------------------------------- Command "/usr/local/opt/python/bin/python3.7 -u -c "import setuptools, tokenize;__file__='/private/var/folders/15/_mc1281d6kn_z8my6cz6dj740000gq/T/pip-install-_4hr8w03/murmurhash3/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /private/var/folders/15/_mc1281d6kn_z8my6cz6dj740000gq/T/pip-record-7a15nstl/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/var/folders/15/_mc1281d6kn_z8my6cz6dj740000gq/T/pip-install-_4hr8w03/murmurhash3/ 

Por otro lado, cuando bash instalar lxml o lxml todo funciona bien. ¿Alguna idea sobre donde he hecho un lío?

La biblioteca murmurhash3 está diseñada para Python> 3.2 y al principio intentabas comstackrlo para Python 2. No funciona porque la biblioteca tiene una extensión C y Python 2 y 3 no son compatibles entre sí con API.

Por supuesto, habría sido más fácil de notar, murmurhash3 habría verificado su versión de Python en su setup.py .

Ahora que estás intentando instalarlo en Python 3, ¡está claro que hay algo muy malo en tu comstackdor! El estándar de C requiere que UCHAR_MAX esté definido en por cada comstackdor de C en existencia y en cualquier architecture de computación personal actual, UCHAR_MAX debe definirse a 255, incluidos los Mac. Python.h comprueba esto. Su comstackdor de C no definió ni UCHAR_MAX ni lo estableció en 255 en limits.h pero aún así incluyó algunos limits.h . Su comstackdor de C es completamente b0rken