Matplotlib.pyplot en OS X con Python de 64 bits de Python.org

Acabo de instalar numpy y matplotlib en mi OS X 10.6.6. Tengo Python 2.7 de Python.org. Cuando hago una import matplotlib.pyplot , obtengo el siguiente error:

 ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/matplotlib/_path.so, 2): no suitable image found. Did find: /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/matplotlib/_path.so: no matching architecture in universal wrapper 

¿Hay algo que me perdí? ¿Cómo puedo solucionar esto?

Actualización 1 (25 de marzo de 2011):
El sistema de trazado interactivo de matplotlib utiliza Tcl / Tk / Tkinter para proporcionar una GUI. Instalé Python de 64 bits, pero no vi las siguientes advertencias en las páginas de descarga de Python.org link1, link2 : http://www.python.org/download/releases/2.7.1/
http://www.python.org/download/mac/tcltk/
Por lo tanto, eliminé la versión de 64 bits e instalé la versión de 32 bits. Le sugiero que mantenga esta pregunta abierta en caso de que salga un Tcl / Tk / Tkinter de 64 bits para Python 2.7.

Si desea una solución sencilla y lista para usar: The Enthought Python Distribution 7.0 (versión académica de 64 bits) me funcionó muy bien en Mac OS X Leopard, incluidos Python 2.7, numpy y matplotlib: https: //www.enthought .com / productos / epd.php

De acuerdo con este mensaje de la lista de correo, la versión actual de matplotlib del instalador no es compatible con la versión de 64 bits de Python de python.org, por lo que necesita la versión de 32 bits.

Por otro lado, ScipySuperpack instala una versión de desarrollo de matplotlib que funciona con Python de 64 bits.

Creo que el paquete matplotlib no está en su sys.path en absoluto. Elimine su matplotlib completamente y vuelva a instalarlo.

Con Python 2.7.2, puede usar ActiveTcl y usar IDLE … Consulte esta nota: http://www.python.org/download/mac/tcltk/