¿Cómo corregir libpapi.so. * No se puede abrir el archivo de objeto compartido cuando se ejecutan (py) COMPS con seguimiento?

Cuando bash ejecutar alguna aplicación COMPS con el sistema de rastreo activado, aparece el siguiente error:

libpapi.so.5.3.0.0 cannot open shared object file 

Estoy usando ubuntu y he instalado COMPS de los paquetes con apt-get. Para lanzar la aplicación utilizo:

 runcompss --tracing --lang=python name_application.py 

Ya instalé las librerías PAPI con:

 apt-get install papi-tools libpapi-dev 

EDITAR: estoy usando la versión 1.4

El sistema de seguimiento no puede encontrar su instalación de PAPI porque los paquetes están precomstackdos.

Para resolver esto, tiene dos opciones: comstackr e instalar desde la fuente el paquete de seguimiento o comstackr e instalar desde la fuente todo el marco COMPS. La forma recomendada sería construir todo el marco para garantizar una instalación limpia. Sin embargo, puede parchear el sistema de rastreo si no desea o no puede instalar la stack de dependencias completas.

Nota: las instrucciones asumen que el directorio de instalación es / opt / COMPSs

Construye todo el framework (recomendado)

Asegúrese de que la instalación anterior se haya eliminado por completo

 sudo apt-get remove compss-* (removes only packages) sudo apt-get purge compss-* (removes also config files) 

Instalar dependencias

 sudo apt-get update # Build dependencies sudo apt-get -y --force-Yes install maven subversion # Runtime dependencies sudo apt-get -y --force-Yes install openjdk-8-jdk graphviz xdg-utils # Bindings-common-dependencies sudo apt-get -y --force-Yes install libtool automake build-essential # Python-binding dependencies sudo apt-get -y --force-Yes install python-dev # C-binding dependencies sudo apt-get -y --force-Yes install libxml2-dev libboost-serialization-dev libboost-iostreams-dev csh # Extrae dependencies sudo apt-get -y --force-Yes install libxml2 gfortran 

Descargar fonts:

 svn co http://compss.bsc.es/svn/releases/compss/1.4 

Construir e instalar

 cd ./1.4/builders sudo -E ./buildlocal /opt/COMPSs 

Construye e instala solo el sistema de seguimiento Extrae

Eliminar el Extrae anterior

 sudo rm -r /opt/COMPSs/Dependencies/extrae 

Instalar dependencias extrae.

 # Extrae dependencies sudo apt-get -y --force-Yes install libxml2 gfortran 

Descargar fonts:

 svn co http://compss.bsc.es/svn/releases/compss/1.4 

Construir e instalar extrae

 cd ./1.4/dependencies/extrae/ sudo ./install /opt/COMPSs/Dependencies/extrae