Error al instalar “Cairocffi”

Estoy trabajando con python3, y estoy tratando de instalarcairocffi ” en Ubuntu. Para hacer esto, he instalado con éxito:

  1. python-dev
  2. libffi-dev
  3. Cffi

Pero cuando intenté instalar “cairocffi” con pip install cairocffi , obtuve:

  File "/usr/local/lib/python3.2/dist-packages/setuptools/dist.py", line 272 , in __init__ _Distribution.__init__(self,attrs) File "/usr/lib/python3.2/distutils/dist.py", line 261, in __init__ self.finalize_options() File "/usr/local/lib/python3.2/dist-packages/setuptools/dist.py", line 327 , in finalize_options ep.load()(self, ep.name, value) File "/usr/local/lib/python3.2/dist-packages/cffi/setuptools_ext.py", line 161, in cffi_modules add_cffi_module(dist, cffi_module) File "/usr/local/lib/python3.2/dist-packages/cffi/setuptools_ext.py", line 48, in add_cffi_module execfile(build_file_name, mod_vars) File "/usr/local/lib/python3.2/dist-packages/cffi/setuptools_ext.py", line 24, in execfile exec(code, glob, glob) File "cairocffi/ffi_build.py", line 30, in  ffi.cdef(constants._CAIRO_HEADERS) AttributeError: 'module' object has no attribute '_CAIRO_HEADERS' ---------------------------------------- Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-y0b_ir/cairocffi 

Mi problema se soluciona instalando una versión específica de cairocffi (versión = 0.6)

 pip install cairocffi==0.6 

Me encontré con esto hoy también. ¿Estás trabajando a través del curso Real Python?

De todos modos, para solucionar el problema, instalé la versión python 3 de python-dev:

 sudo apt-get install python3-dev sudo apt-get install libffi-dev sudo pip3 install cffi sudo pip3 install cairocffi 

¡Espero que esto ayude!

instalar el paquete libffi-dev puede solucionar este problema simplemente ejecute sudo apt install libffi-dev