Articles of centos

Instale lxml en Centos 7 – error: el comando ‘gcc’ falló con el estado de salida 4

Estoy usando python 3.4 en un entorno virtual: (af)[root@domain backend]# pip –version pip 7.1.0 from /home/af/af-stage/backend/.ves/af/lib/python3.4/site-packages (python 3.4) La instalación de lxml falló “error: el comando ‘gcc’ falló con el estado de salida 4”: (af)[root@domain backend]# pip install lxml You are using pip version 7.1.0, however version 7.1.2 is available. You should consider upgrading via […]

(aún) no puede instalar correctamente lxml 2.3 para python, pero al menos 2.2.8 funciona

30 de junio de 2011 : estoy otorgando a @Pablo por esta pregunta, debido a su respuesta . Todavía no puedo instalar correctamente el lxml 2.3 por los motivos que se comentan en sus comentarios. Me reúno para un poco de trabajo que pueda, pero ya he pasado una cantidad de tiempo ridícula en este […]

Cómo instalar libpython2.7.so

He instalado Python 2.6.6 en [17:50:21 root@data.dev:~]# which python /usr/local/bin/python también Python 2.7.6 en [17:51:12 root@data.dev:~]# which python2.7 /usr/local/bin/python2.7 Pero falta libpython2.7.so [17:48:52 root@data.dev:~]# locate libpython2.6.so /usr/lib64/libpython2.6.so /usr/lib64/libpython2.6.so.1.0 /usr/lib64/python2.6/config/libpython2.6.so [17:48:56 root@data.dev:~]# locate libpython2.7.so [17:49:02 root@data.dev:~]# No sé cómo arreglar esto. Alguien puede ayudar ?

bdist_rpm de Ubuntu a CentOs

Desarrollamos en Ubuntu / Mac e implementamos RPM en CentOS (esta es la configuración, no se puede cambiar mucho). El problema es que al instalar desde el rpm, los paquetes van a /usr/local/lib/python2.7/dist-packages (que es la ubicación correcta para Ubuntu). Sin embargo, la ruta de Python predeterminada en CentOS está buscando en /usr/local/lib/python2.7/site-packages . ¿Hay […]

error: el comando ‘gcc’ falló con el estado de salida al instalar psycopg2

Necesito instalar psycopg2 para el proceso de instalación de openerp , pero siempre encontré ese error. Ya he usado pip y easy_install , mi gcc es la última versión. Realmente necesito tu ayuda para resolver mi problema … este es mi error completo con easy_install .. [root@server01 ~]# easy_install psycopg2 Searching for psycopg2 Reading http://pypi.python.org/simple/psycopg2/ […]

ffmpeg se cuelga cuando se ejecuta en segundo plano

Si ejecuto ffmpeg como sigue: ffmpeg -i H264-media-4.264 4.avi Funciona bien (es decir, 4.avi creado correctamente). Sin embargo, si bash ejecutarlo en segundo plano: ffmpeg -i H264-media-4.264 4.avi & se cuelga! (y 4.avi nunca creado) ¿Alguna idea? Nota: El problema es un aislamiento de un problema similar en Python cuando se intenta ejecutar como subproceso […]

Instale Python 2.6 en CentOS

Tengo un shell que ejecuta CentOS. Para un proyecto que estoy haciendo, necesito Python 2.5+, pero centOS depende bastante de 2.4. Por lo que he leído, una serie de cosas se romperán si actualiza a 2.5. Quiero instalar 2.5 por separado de 2.4, pero no estoy seguro de cómo hacerlo. Hasta ahora, he descargado el […]

¿Cómo usar una versión diferente de python durante la instalación de NPM?

Tengo acceso de terminal a un VPS con centos 5.9 y Python 2.4.3 predeterminado instalado. También instalé Python 2.7.3 a través de estos comandos: (Utilicé make altinstall lugar de make install ) wget http://www.python.org/ftp/python/2.7.3/Python-2.7.3.tgz tar -xf Python-2.7.3.tgz cd Python-2.7.3 ./configure make make altinstall Luego instalé node.js desde la fuente a través de estos comandos: python2.7 […]

Error al instalar Python

Al golpear make install Obtuve el siguiente error /usr/bin/install: cannot create regular file /usr/local/bin/python2.6: Permission denied make: *** [altbininstall] Error 1 No soy el usuario root, así que asumo que es un problema de permisos. Tengo mi propia subcarpeta en /home/my_username ¿Hay alguna manera de completar la instalación de Python allí dando un comando más […]

pip: problemas de permisos inconsistentes

Al instalar un paquete a través de sudo pip-python (paquete CentOS 6: python-pip-0.8-1.el6.noarch ), a veces tengo problemas con los permisos para que los paquetes instalados sean legibles solo por root. Reinstalar de nuevo una o dos veces generalmente soluciona el problema. Alguien ha experimentado esto? ¿O puede alguien sugerir algún paso para solucionar el […]