Articles of fácil instalación

Instalar pip en macOS no funciona (ya)

Seguí las instrucciones en línea sobre cómo instalar pip en macOS (por ejemplo, esto , esto y esto ). Todo parece simple, pero no funciona para mí. Mi versión de python –version es 2.7.10. Cuando ejecuto sudo easy_install pip obtengo: $ sudo easy_install pip Password: Searching for pip Reading http://pypi.python.org/simple/pip/ Couldn’t find index page for […]

¿easy_install falla en el error “No se pudo encontrar el script de configuración” después de la carga binaria?

Después de cargar una distribución binaria de mi extensión Python C con la python setup.py bdist upload , easy_install [my-package-name] falla en “error: No se pudo encontrar un script de configuración en / tmp / easy_install / package-name-etc- etc “. ¿Qué estoy haciendo mal?

Agregando bibliotecas a Python portátil

Así que actualmente estoy usando python portátil y necesito agregar la biblioteca de neurolab. En la línea de comandos intenté moverme al directorio de scripts y ejecutar easy_install.exe neurolab Luego, se abre otra ventana de línea de comando y se encuentra el proyecto de neurolab en el código de Google y sus archivos de listado. […]

No se puede instalar con easy_install o pip en mac

Estoy intentando instalar los módulos lxml y pycrypto usando easy_install (y pip) pero obtengo mensajes de error como Running lxml-2.3.4/setup.py -q bdist_egg –dist-dir /tmp/easy_install-kGsWMh/lxml-2.3.4/egg-dist-tmp-Gjqy3f Building lxml version 2.3.4. Building without Cython. Using build configuration of libxslt 1.1.24 In file included from /usr/include/limits.h:63, from /Developer/usr/bin/../lib/gcc/powerpc-apple-darwin10/4.0.1/include/limits.h:10, from /Library/Frameworks/Python.framework/Versions/2.6/include/python2.6/Python.h:19, from src/lxml/lxml.etree.c:4: /usr/include/sys/cdefs.h:540:4: error: #error Unknown architecture In file […]

Problema con easy_install-2.7

Después de instalar easy_install e intentar usarlo para luego instalar un paquete de Python, falla. [root@server]# easy_install-2.7 pip Searching for pip Reading http://pypi.python.org/simple/pip/ Download error on http://pypi.python.org/simple/pip/: unknown url type: https — Some packages may not be found! Me parece que tengo un redireccionamiento curl -IL http://pypi.python.org/simple/pip/ HTTP/1.1 301 Moved Permanently Retry-After: 0 Location: https://pypi.python.org/simple/pip/ […]

Python actualizado en Snowleopard El uso de Homebrew ahora pip y easy_install no funcionan

Soy nuevo en Python, he cambiado mi ruta para apuntar a la nueva Python 2.7, pero pip y easy_install, y mercurial todavía están buscando la versión 2.6 instalada por defecto. ¿Cómo puedo solucionar esto?

Easy_install de Python y ubicación de cabecera / biblioteca personalizada

Estoy tratando de instalar adns-python usando linux y tuve que adns a comstackr adns con algunas opciones especiales, así que parece que no puedo usar easy_install como lo haría normalmente (py26_default)[mpenning@localhost src]$ easy_install adns-python-1.2.1.tar.gz Processing adns-python-1.2.1.tar.gz Running adns-python-1.2.1/setup.py -q bdist_egg –dist-dir /tmp/easy_install-9cVl4i/adns-python-1.2.1/egg-dist-tmp-vvO8Ms adnsmodule.c:10:18: error: adns.h: No such file or directory adnsmodule.c:31: error: expected specifier-qualifier-list before […]

¿Cómo arreglar la instalación de Python Numpy / Pandas?

Me gustaría instalar la biblioteca de Python Pandas (0.8.1) en Mac OS X 10.6.8. Esta biblioteca necesita Numpy> = 1.6. Probé esto $ sudo easy_install pandas Searching for pandas Reading http://pypi.python.org/simple/pandas/ Reading http://pandas.pydata.org Reading http://pandas.sourceforge.net Best match: pandas 0.8.1 Downloading http://pypi.python.org/packages/source/p/pandas/pandas-0.8.1.zip#md5=d2c5c5bea971cd760b0ae6f6850fcb74 Processing pandas-0.8.1.zip Running pandas-0.8.1/setup.py -q bdist_egg –dist-dir /tmp/easy_install-ckAMym/pandas-0.8.1/egg-dist-tmp-0mlL7t error: Setup script exited with pandas […]

Instalación de numpy en Amazon EC2

Tengo problemas para instalar numpy en un servidor de Amazon EC2. He intentado usar easy_install, pip, pip dentro de un entorno virtual, pip dentro de otro entorno virtual usando python 2.7 … Cada vez que lo bash, falla con el error: gcc: internal compiler error: Killed (program cc1) , y más adelante en la línea […]

¿Puede pip (o setuptools, distribuir, etc.) enumerar la licencia utilizada por cada paquete instalado?

Estoy intentando auditar un proyecto de Python con una gran cantidad de dependencias y aunque puedo buscar manualmente los términos de la página de inicio / licencia de cada proyecto, parece que la mayoría de los paquetes OSS ya deberían contener el nombre de la licencia y la versión en sus metadatos. Desafortunadamente, no puedo […]