Articles of instalación

Install_requires basado en la versión de python

Tengo un módulo que funciona tanto en python 2 como en python 3. En Python = 3.2. Algo como: install_requires=[ “threadpool >= 1.2.7 if python_version < 3.2.0", ], ¿Cómo se puede hacer eso?

Django dice: ningún módulo llamado ‘blog’

Recibo el “ModuleNotFoundError: No module named ‘blog'” cuando agrego la aplicación de mi blog a la sección INSTALLED_APPS de settings.py . He determinado que tiene algo que ver con la forma en que agregué la aplicación “blog” en INSTALLED_APPS. Cuando elimino la referencia ‘blog’ de INSTALLED_APPS error desaparece. ¿Parece que Django no puede encontrar el […]

Cómo empezar a usar `scipy`

Previamente instalé Python 3.4.2 y 3.5.2 y en ambos casos puedo incursionar en escribir y probar código en Inactivo, lo que me brinda dos ventanas: una ventana “Ejecutar” para el código y una ventana “Shell” para la interacción y salida (lo siento, no estoy seguro de la terminología correcta). Ahora me gustaría probar scipy , […]

Python en Mac OS Pycharm da error de marco con “importar matplotlib.pyplot como plt”

Esta pregunta es similar a las de aquí y aquí, pero ninguna de las soluciones allí funciona, quizás porque estoy usando un entorno diferente (PyCharm en Mac OS). En un entorno virtual con PyCharm ejecutándose en 2.7.15, matplotlib instalado sin ninguna queja, y un archivo de Python de PyCharm de una línea con el siguiente […]

Instale xgboost en python con un error de msys de 32 bits

¿Intentando instalar xgboost está fallando …? La versión es Anaconda 2.1.0 (64 bits) en Windows y en la empresa. ¿Cómo procedo? He estado usando R parece que es bastante fácil instalar un nuevo paquete en R desde RStudio, pero no tanto en spyder, ya que necesito ir a una ventana de comandos para hacerlo y […]

Problemas de instalación de Python PyAudio (con PortAudio)

Estoy intentando escribir un progtwig para grabar información desde el micrófono de mi computadora y guardarlo en un archivo. PyAudio parece ser uno de los mejores paquetes para hacer esto, e incluso tienen un binario para Windows 7 (Python 2.7). Descargué el archivo ejecutable y lo ejecuté para configurar PyAudio, pero cuando bash importar PyAudio […]

pip y virtualenv (sin virtualenvwrapper): pip install package_name da permiso denegado, pero al usar sudo se instala globalmente

Tengo el paquete de 0.2.0 versión 0.2.0 en /usr/local/lib/python2.7/dist-packages . Ahora me gustaría instalar la versión 0.1.0 neurolab en un entorno virtual. Esto es después de instalar pip y virtualenv: ~$ mkdir neuro_env ~$ cd neuro_env ~/neuro_env$ virtualenv envi ~/neuro_env$ source envi/bin/activate (envi)~/neuro_env$ pip install neurolab==0.1.0 Luego la instalación falla, con al final del error […]

Actualice Python en Mac de 2.7 a 3.6 (o más reciente) para el cliente elástico de beanstalk AWS

Estoy tratando de seguir las instrucciones aquí, pero no importa lo que haga, parece que está atascado en el uso de Python 2.7.1 que me está causando errores actualmente. http://docs.aws.amazon.com/elasticbeanstalk/latest/dg/eb-cli3-install-osx.html Se adjunta una imagen que muestra mis registros de actualización a la versión más reciente de awsebccli, pero aún está bloqueado diciendo 2.7.1 cuando debería […]

Python: mudarse a una nueva computadora

Estoy pasando de una computadora con Windows XP a una con Windows 7 (64 bits) y quiero instalar Python en la nueva máquina. Actualmente estoy usando Python 2.7 y 3.2 y un montón de paquetes 1) ¿Debo instalar las versiones de 64 bits? 2) ¿Cómo puedo saber qué paquetes tengo actualmente, para poder obtenerlos para […]

¿Cómo hacer que easy_install ejecute comandos personalizados en setup.py?

Quiero que setup.py realice algunas acciones personalizadas además de instalar el paquete Python (como instalar un script init.d, crear directorios y archivos, etc.) Sé que puedo personalizar las clases distutils / setuptools para que realicen mis propias acciones. El problema que tengo es que todo funciona cuando cd al directorio del paquete y hago “python […]