Articles of macos de

Error de biblioteca PyCrypto y GMP no encontrado

Estoy tratando de instalar pycrypto-2.1.0 pero bash hacerlo con ‘python setup.py build’ : running build running build_py running build_ext warning: GMP library not found; Not building Crypto.PublicKey._fastmath. Instalé GMP (gmp-4.3.2) y está en: /usr/local/lib ¿Cómo puedo hacer que python / pycrypto reconozca que GMP ya está presente en mi sistema? Mac OS: 10.6.3 versión de […]

¿Cómo abro un archivo de texto en TextEdit de Python en Mac?

else: tkMessageBox.showinfo(‘Report Created’, ‘Your report was sucessfully created’) file = ‘Student Report.txt’ os.system(‘TextEdit’+file) Estoy escribiendo un progtwig que crea un informe a partir de datos de una base de datos, escribe esos datos en un archivo de texto y luego se supone que debe iniciar ese archivo de texto para poder imprimirlo. ¿Cómo logro esto? […]

socket.error: Operación no admitida en socket

Estoy usando Python en Mac. Pero el código de abajo import socket s = socket.socket(socket.AF_INET, socket.SOCK_DGRAM) s.bind((‘127.0.0.1’, 443)) s.listen(2048) encuentra el problema Traceback (most recent call last): File “attacker.py”, line 5, in s.listen(2048) File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py”, line 228, in meth return getattr(self._sock,name)(*args) socket.error: [Errno 102] Operation not supported on socket Cómo resolver este problema?

¿Mac es bueno para la progtwigción de Python?

Estoy progtwigndo un sitio web basado en django. En realidad uso una pequeña computadora bajo Ubuntu 10.04. Me gustaría comprar algo más profesional, por lo que me pregunto si un iMac es bueno para eso, porque: ¿Existe un IDE gratuito tan bueno como un eclipse en MacOS? ¿Hay un depurador de python remoto como pydev […]

Error de importación de Python: no se encontró el símbolo, pero el símbolo es * no está * presente en el archivo

Recibo este error cuando bash importar ssrc.spread : ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/ssrc/_spread.so, 2): Symbol not found: __ZN17ssrcspread_v1_0_67Mailbox11ZeroTimeoutE El archivo en cuestión ( _spread.so ) incluye el símbolo: $ nm _spread.so | grep _ZN17ssrcspread_v1_0_67Mailbox11ZeroTimeoutE U __ZN17ssrcspread_v1_0_67Mailbox11ZeroTimeoutE U __ZN17ssrcspread_v1_0_67Mailbox11ZeroTimeoutE (dos veces porque el archivo es un binario ppc / x86 gordo) EDITAR: de acuerdo, como señala James, la U […]

OS X Desinstalar un proyecto instalado en los distritos.

Estoy en El Capitán y quiero instalar numpy con pip. Sin embargo me sale el siguiente error: Detected a distutils installed project (‘numpy’) which we cannot uninstall. The metadata provided by distutils does not contain a list of files which have been installed, so pip does not know which files to uninstall. La versión numpy […]

Cómo forzar a py2app a ejecutar la aplicación en modo de 32 bits

Estoy intentando crear un paquete de aplicaciones con py2app en Mac OS X 10.6. La aplicación utiliza algunas bibliotecas que solo se comstackn para 32 bits, de modo que cuando se ejecuta la aplicación hay un ImportError “no hay una architecture de 64 bits apropiada”. ¿Cómo puedo decirle a py2app que obligue a la aplicación […]

¿Por qué cuando se usa sys.platform en Mac para imprimir “darwin”?

En Python, cuando escribo sys.platform en Mac OS X, ¿el resultado es “darwin”? ¿Por qué esto es tan?

Historial de modo interactivo de Python y teclas de flecha

Me preguntaba si alguien puede explicar por qué, de repente, en el modo interactivo de Python, todas las teclas de flecha están fallando. Cuando presiono el botón arriba, por ejemplo, para pasar por el historial de comandos, obtengo “^ [[A”. Lo mismo con cualquier otra tecla de flecha. No tengo idea de por qué sucedió […]

“Este paquete no debe estar accesible en Python 3” cuando se ejecuta python3

Estaba intentando usar virtualenv para cambiar entre las versiones de python antes de saber que podía usar tanto python como python3 en mi Mac. Tuve la oportunidad de arreglar mi versión de Python 2.7 para que aún funcione bien, sin embargo, ahora cuando ejecuto Python3, recibo este error: Failed to import the site module Traceback […]