Articles of macports

pip instala los paquetes con éxito, pero los ejecutables no se encuentran desde la línea de comandos

Estoy trabajando en mac OS X Yosemite, versión 10.10.3. Instalé python2.7 y pip usando macport como se hace en http://johnlaudun.org/20150512-installing-and-setting-pip-with-macports/ Puedo instalar paquetes con éxito e importarlos dentro de mi entorno de Python y los scripts de Python. Sin embargo, no se encuentra ningún ejecutable asociado con un paquete al que se pueda llamar desde […]

Comandos de selección de puertos Macports

Cuáles son los nuevos comandos y equivalentes de: python_select -L (shows available python versions) python_select -s (sets the default version of your choice of python). Sé que han cambiado a –list , –set , –show pero no parece haber un ejemplo de cómo usarlos correctamente. Por ejemplo, si uso port select –set obtengo lo siguiente: […]

La instalación de Python no puede encontrar psycopg2 ImportError

Estoy llamando a psycopg2 con import psycopg2 Me sale el error std ImportError: No hay módulo llamado psycopg2 Instalé mi copia con macports, así que tengo curiosidad de por qué no funcionaría porque todas las dependencias también deberían descargarse. No tengo ninguna experiencia con Postgresql, ni con este módulo, así que no sé qué podría […]

Cómo instalar los enlaces de Python 2.7 para OpenCV usando MacPorts

Cuando bash “importar cv” en python, obtengo: “ImportError: No hay un módulo llamado cv”. Esta pregunta ha aparecido en muchas formas, pero no he encontrado la respuesta que ayude. En mi Mac OS X Lion, entre muchos otros puertos, he ejecutado: sudo port install python27 y sudo port install opencv +python27 Corriendo: port select python […]

¿Cómo desinstalo python de OSX Leopard para poder usar la versión de MacPorts?

Quiero usar la versión de macports de python en lugar de la que viene con Leopard.

Problemas para configurar la versión de Python en Sublime Text2

Tengo problemas para configurar el entorno de comstackción en Sublime Text2. Estoy usando Macports para Python y la instalación de paquetes. Mi archivo python.sublime-build tiene este aspecto: { “cmd”: [“python”, “-u”, “$file”], “file_regex”: “^[ ]*File \”(…*?)\”, line ([0-9]*)”, “selector”: “source.python” } Creo (de la búsqueda) que necesito modificar la línea “cmd” para apuntar a la […]

No se puede instalar matplotlib en Mac OS X

Estoy tratando de instalar matplotlib para aplicaciones gráficas en Python en Mac OS X. Cuando ejecuto “python setup.py install”, me da esta carga de errores: http://pastebin.com/u7fL37ic . Un fragmento rápido: src/ft2font.cpp:2170: error: ‘FT_LOAD_TARGET_MONO’ was not declared in this scope src/ft2font.cpp:2171: error: ‘FT_LOAD_TARGET_LCD’ was not declared in this scope src/ft2font.cpp:2172: error: ‘FT_LOAD_TARGET_LCD_V’ was not declared in […]

macports no colocó python_select en / opt / local / bin

He desinstalado y reinstalé python_select usando MacPorts y, sin embargo, no aparecerá en / opt / local / bin. En consecuencia, recibo un error de “comando no encontrado” al intentar ejecutarlo. Sin embargo, MacPorts insiste en que está instalado. Incluso he intentado desinstalar -f y port clean –all python_select. ¿Hay algún paso más drástico para […]

Cómo: Macports seleccionar python

Cuando entro: port select –list python Este es el resultado: Available versions for python: none python25 (active) python25-apple python26-apple python27 python27-apple Pensé que cuando usara python estaría usando la versión 2.5 . En cambio, cuando ingreso a “python”, la versión 2.7 parece estar activa. ¿Cómo cambio eso a la versión 2.5? Python 2.7.1 (r271:86832, Jun […]

¿Cuál es la forma más compatible de instalar módulos de python en una Mac?

Estoy empezando a aprender python y me encanta. Trabajo en una Mac principalmente, así como en Linux. Estoy encontrando eso en Linux (Ubuntu 9.04 en su mayoría) cuando instalo un módulo de Python usando apt-get funciona bien. Puedo importarlo sin problemas. En la Mac, estoy acostumbrado a usar Macports para instalar todo el material de […]