Articles of osx lion

Instale pyUSB 0.4.3 en OSX Lion 10.7.3

Estoy tratando de instalar pyusb 0.4.3 en Mac OS X Lion 10.7.3 ejecutando Xcode 4.3 (la nueva App Store de Mac con las herramientas de línea de comandos instaladas). Cuando bash “python setup.py install” obtengo esta larga lista de errores que terminan con “error: el comando ‘llvm-gcc-4.2’ falló con el estado de salida 1”: http://pastebin.com/R8id7Qf7 […]

Instalación y configuración correctas de Python / Pyside / PyDev en OS X Lion (y versiones futuras probables de OS X)

Estoy teniendo problemas con PyDev al no completar automáticamente el campo, sospecho que me estoy perdiendo un paso crucial en el proceso de instalación. Entonces, ¿cómo se instala y configura una nueva instalación de OS X lion para desarrollar pyside? Nota: Esta pregunta NO pertenece a otro sitio de stack. Esto es lo que tiene […]

Permiso denegado error al intentar instalar pip en Mac OS X Lion

Estoy tratando de instalar pip en una Mac (OS X Lion). No parece funcionar. Yo uso sudo y se me pide contraseña. $ sudo curl https://raw.github.com/pypa/pip/master/contrib/get-pip.py | python % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 85929 100 85929 0 0 63833 0 0:00:01 […]

¿Cómo hacer que virtualenv funcione después de actualizar a Lion?

Acabo de actualizar de SnowLeapord a Lion y ahora no puedo crear virtualesenvs. Entiendo que hay nuevas instalaciones de Python después de la actualización y no hay paquetes de sitio y he intentado instalar pip y virtualenv nuevamente, así como la actualización a Xcode4, pero siempre recibo este error: ~ > virtualenv –distribute env New […]

¿Cómo usar libxml2 con python en macOs?

Estoy en OSX Lion y tengo libxml2 instalado (por defecto) y tengo python instalado (por defecto) pero no se hablan entre sí. ¿Cuál es la forma más sencilla de hacer que esto funcione en Lion? $ python -c “import libxml2” Traceback (most recent call last): File “”, line 1, in ImportError: No module named libxml2

¿Cómo puedo instalar la biblioteca de Python ‘gevent’ en Mac OS X Lion?

La biblioteca gevent Python, versión 0.13.6 (la versión actual en PyPI) no se pip install en OS X Lion, Python 2.7 (y probablemente otros). Funciona bien en Snow Leopard. ¿Cómo puedo obtener esta biblioteca instalada? Puntos de bonificación si se puede hacer usando pip install , en lugar de un proceso manual o personalizado, porque […]

Uso del módulo de multiprocesamiento python para IO con pygame en Mac OS 10.7

Uso pygame para realizar experimentos en ciencia cognitiva, y con frecuencia tengo grandes demandas de E / S, por lo que me gusta dividir estas tareas en procesos separados (cuando se utiliza una máquina de múltiples núcleos) para mejorar el rendimiento de mi código. Sin embargo, me encontré con un escenario en el que algunos […]

¿Por qué recibo el error: el comando ‘llvm-gcc-4.2’ falló con el estado de salida 1

Estoy configurando os X 10.7. Estoy usando la instalación predeterminada de Python: /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/ Uso un gestor de paquetes basado en Python llamado easy_install. Easy_install parece no poder encontrar el comstackdor. EDITAR: cuando intenté instalar MySQL-python obtuve este error: $ sudo easy_install MySQL-python Password: Searching for MySQL-python Reading http://pypi.python.org/simple/MySQL-python/ Reading http://sourceforge.net/projects/mysql-python/ Reading http://sourceforge.net/projects/mysql-python Best match: MySQL-python […]

Numpy y Scipy para Python 2.6.7 preinstalado en Mac OS Lion

¿Hay alguna forma de instalar numpy y scipy en Python 2.6.7 que viene con Mac OS Lion? Soy consciente de que Lion también tiene Python 2.7. Pero necesito seguir con Python 2.6 porque estoy usando un módulo que no funciona en Python 2.7.

La instalación de Python no puede encontrar psycopg2 ImportError

Estoy llamando a psycopg2 con import psycopg2 Me sale el error std ImportError: No hay módulo llamado psycopg2 Instalé mi copia con macports, así que tengo curiosidad de por qué no funcionaría porque todas las dependencias también deberían descargarse. No tengo ninguna experiencia con Postgresql, ni con este módulo, así que no sé qué podría […]