Articles of paquete

Conflicto de importación de Python

Recientemente construí un paquete Python y lo instalé a través del empaquetador de Debian. Está instalado en mi sistema para que pueda usarlo en otros proyectos. En mi nuevo proyecto tengo el mismo nombre de una carpeta de paquete, a saber, opal. Escanee la web incluyendo este sitio y todo lo que apunta a usar: […]

Descomprimir una carga gzip de un paquete con Python

Actualmente estoy trabajando en un progtwig que toma un archivo .pcap y separa todos los paquetes por ip usando el paquete scapy. Quiero descomprimir las cargas útiles que están comprimidas usando el paquete gzip. Puedo decir si la carga útil está comprimida porque contiene Content-Encoding: gzip Estoy tratando de usar fileStream = StringIO.StringIO(payload) gzipper = […]

¿Los módulos de Python 3 y la importación relativa del paquete no funcionan?

Tengo algunas dificultades para construir la estructura de mi proyecto. Esta es la estructura de mi directorio de proyectos: MusicDownloader/ __init__.py main.py util.py chart/ __init__.py chart_crawler.py test/ __init__.py test_chart_crawler.py Estos son los códigos: 1.main.py from chart.chart_crawler import MelonChartCrawler crawler = MelonChartCrawler() 2.test_chart_crawler.py from ..chart.chart_crawler import MelonChartCrawler def test_melon_chart_crawler(): crawler = MelonChartCrawler() 3.chart_crawler.py import sys sys.path.append(“/Users/Chois/Desktop/Programming/Project/WebScrap/MusicDownloader”) […]

¿Qué significa “los siguientes paquetes serán reemplazados por un canal de mayor prioridad”?

Descargo de responsabilidad: soy un ignorante Linux + Anaconda noob. Ahora, con eso fuera del camino: estoy tratando de instalar fuzzywuzzy en mi distribución Anaconda en Linux de 64 bits. Cuando hago esto, intenta cambiar mi conda , y conda-env a canales conda-forge . Como sigue: Busco anaconda fuzzy wuzzy escribiendo: anaconda search -t fuzzywuzzy […]

Creando un instalador de Windows para Python + un conjunto de dependencias

Necesito crear un instalador para Windows que debería poder instalar una versión específica del intérprete de Python (2.7) más un conjunto de dependencias como ipython, numpy, pandas, etc. Básicamente, esto es lo mismo que hizo Active State para su distribución de Python activo: un solo paquete que incluye intérprete + deps. Al no ser un […]

python: dos módulos y clases con el mismo nombre en diferentes paquetes

He empezado a aprender python y escribir una aplicación de práctica. La estructura del directorio parece src | –ShutterDeck | –Helper | –User.py -> class User –Controller | –User.py -> class User El directorio src está en PYTHONPATH . En un archivo diferente, digamos main.py , quiero acceder a las dos clases de User . […]

Creación del paquete PyPi: no se pudo encontrar una versión que cumpla con el requisito iso8601

Estoy creando un paquete PyPi con pip y tratando de probar que funciona en el entorno de prueba ( https://testpypi.python.org/pypi ). Ahora mismo tengo un paquete que parece existir en la instalación de PyPi prod, pero no en la prueba. Si instalo la dependencia con prod PyPi (es decir, pip install iso8601 == 0.1.4) funciona […]

¿Qué paquete de Eclipse debería descargar para PyDev?

¿Qué paquete de Eclipse debería elegir para el desarrollo de Python con PyDev ? Nada en la página de inicio de Eclipse me dice qué elegir, y la documentación de PyDev asume que ya tengo Eclipse instalado. ¿Importa qué paquete de Eclipse elijo?

Instalé un paquete con Anaconda, no se puede importar en Python

Perdóname pero soy nueva en python. He instalado un paquete (theano) usando conda install theano , y cuando conda list , el paquete existe Sin embargo, cuando entro en el intérprete de python ejecutando python , y trato de importarlo con import theano , import theano un error: “no hay un módulo llamado theano”, y […]

Paquete de espacio de nombres con tarball y egg en Python

He seguido este tutorial para hacer un paquete con espacio de nombres. Luego uso pip install xxx.tar.gz para instalar y todo funciona como espera. El problema es que mi entorno ya tiene muchos paquetes con el mismo espacio de nombres e instalado con easy_install y eggs , y Python ya no puede encontrar los paquetes […]