Articles of pip de

Python actualizado en Snowleopard El uso de Homebrew ahora pip y easy_install no funcionan

Soy nuevo en Python, he cambiado mi ruta para apuntar a la nueva Python 2.7, pero pip y easy_install, y mercurial todavía están buscando la versión 2.6 instalada por defecto. ¿Cómo puedo solucionar esto?

Solución de problemas de Python: ImportError: no se puede importar el nombre ‘main’

Estoy enfrentando un problema con la instalación del paquete, pip. Estoy usando Python 3.6. Cuando bash instalar un paquete con pip, recibo el siguiente mensaje en el cmd. *C:\Python36\Scripts>pip intstall –user httpie Traceback (most recent call last): File “c:\python36\lib\runpy.py”, line 193, in _run_module_as_main “__main__”, mod_spec) File “c:\python36\lib\runpy.py”, line 85, in _run_code exec(code, run_globals) File “C:\Python36\Scripts\pip.exe\__main__.py”, […]

¿Cómo comstackr las dependencias de C ++ durante la instalación de pip?

Quiero hacer que mi código de Python sea compatible. Sin embargo, mi código depende de otra biblioteca que no es pipeable. Por lo tanto, de alguna manera necesito comstackr el código fuente cuando un usuario llama a pip install . ¿Cómo puedo hacer eso? No he podido encontrar una buena referencia a través de búsquedas […]

Instalación de numpy en Amazon EC2

Tengo problemas para instalar numpy en un servidor de Amazon EC2. He intentado usar easy_install, pip, pip dentro de un entorno virtual, pip dentro de otro entorno virtual usando python 2.7 … Cada vez que lo bash, falla con el error: gcc: internal compiler error: Killed (program cc1) , y más adelante en la línea […]

¿Puede pip (o setuptools, distribuir, etc.) enumerar la licencia utilizada por cada paquete instalado?

Estoy intentando auditar un proyecto de Python con una gran cantidad de dependencias y aunque puedo buscar manualmente los términos de la página de inicio / licencia de cada proyecto, parece que la mayoría de los paquetes OSS ya deberían contener el nombre de la licencia y la versión en sus metadatos. Desafortunadamente, no puedo […]

python setup.py egg_info falló con el código de error 1

Estoy ejecutando Ubuntu 17.04 (instalación nueva) y pip ya instalado. Sin embargo, cuando bash instalar algo obtengo esto: El comando “python setup.py egg_info” falló con el código de error 1 en / tmp / pip-build-kBfUEp / kivy / Dependiendo de lo que esté instalando, obtengo lo mismo pero ligeramente diferente. Por ejemplo: El comando “python […]

ImportError: no se puede importar el nombre ‘_BACKCOMPAT_MAGIC_NUMBER’

Intentando usar pip para instalar, acaba de instalar otra versión de python (3.4) obtener error ImportError: cannot import name ‘_BACKCOMPAT_MAGIC_NUMBER’

virtualenv, mysql-python, pip: ¿alguien sabe cómo?

Estoy tratando de instalar los enlaces mysql en un virtualenv. Prefiero usar pip o easy_install. pip me da el siguiente error: File “setup_posix.py”, line 24, in mysql_config raise EnvironmentError(“%s not found” % (mysql_config.path,)) EnvironmentError: mysql_config not found easy_install obtiene un 404 de sourceforge o me da un error muy similar. ¿Alguien sabe cómo solucionar esto […]

error pip / easy_install: no se pudo crear el proceso

Después de seguir este artículo: ¿Cómo instalo pip en Windows? en mi sistema Windows que utiliza el sistema Enthought Canopy 64 Bit, no puedo hacer que pip o easy_install funcionen debido a un error pip install requests failed to create process Intenté reinstalar setuptools, ejecutando el indicador de cmd como administrador sin ningún efecto.

¿Cómo instalar pip para python 2.6?

Intenté seguir las instrucciones de esta respuesta, pero easy_install-2.6 no pudo encontrar pip : >sudo easy_install-2.6 pip Processing pip error: Not a recognized archive type: pip ¿Cómo instalo pip para python 2.6? Mi necesidad de raíz para pip para 2.6 se explica en este hilo .