Articles of ubuntu

falta el módulo zlib

He comstackdo e instalado python 2.7 en mi ubuntu lucid. Pero no puedo instalar setuptools para python 2.7 porque el módulo de descompresión de datos zlib no está presente. Este es el error exacto: Traceback (most recent call last): File “setup.py”, line 94, in scripts = scripts, File “/usr/local/lib/python2.7/distutils/core.py”, line 152, in setup dist.run_commands() File […]

¿Dónde está Pip3 instalando módulos?

Ubuntu 15.10 Python 3.4.3+ Django 1.8.7 Cuando bash import django en el intérprete de python3, dice ImportError: No module named ‘django’ . Sin embargo, sé que Django 1.8.7 está instalado, porque puedo obtener la versión # haciendo django-admin –version en la línea de comandos del terminal. Cuando probé python3 manage.py runserver en un directorio de […]

Ubuntu: ¿Cómo instalar un módulo de Python (BeautifulSoup) en Python 3.3 en lugar de Python 2.7?

Tengo este código (como está escrito en la documentación BS4): from bs4 import BeautifulSoup Cuando ejecuto el script (usando python3) me sale el error: ImportError: No module named ‘bs4’ Así instalado BeatifulSoup por: sudo pip install BeatifulSoup4 Pero cuando bash volver a ejecutar el script, aparece el mismo error. De hecho BS4 está instalado en: […]

error de protocolo al configurar entorno virtual a través de vagrant en ubuntu

Estoy intentando configurar un virtualenv en Ubuntu 12.04 con Python 2.7 usando vagrant pero teniendo los mismos problemas. Parece que estos problemas se ven solo cuando se emite “vagrant up” desde Windows. ¿cuál es la solución? cualquier punteros? New python executable in .vagrant-env/bin/python Traceback (most recent call last): File “/usr/local/bin/virtualenv”, line 9, in load_entry_point(‘virtualenv==1.11.6’, ‘console_scripts’, […]

Permiso denegado al iniciar el script de Python a través de bash

# ./scripts/replace-md5sums.py bash: ./scripts/replace-md5sums.py: Permission denied replace-md5sums.py tiene chmod 600 # ls -l ./scripts/replace-md5sums.py -rw——- 1 ubuntu ubuntu 661 2011-04-27 16:30 ./scripts/replace-md5sums.py

Ayúdame a entender por qué Unicode solo funciona a veces con Python

Aquí hay un pequeño progtwig: #!/usr/bin/env python # -*- encoding: utf-8 -*- print(‘abcd kΩ ☠ °C √Hz µF ü ☃ ♥’) print(u’abcd kΩ ☠ °C √Hz µF ü ☃ ♥’) En Ubuntu, Gnome terminal, IPython hace lo que yo esperaría: In [6]: run Unicodetest.py abcd kΩ ☠ °C √Hz µF ü ☃ ♥ abcd kΩ […]

La distribución ‘pip == 7.1.0’ no se encontró y es requerida por la aplicación

Tengo la última versión de pip 8.1.1 en mi ubuntu 16. Pero no puedo instalar ningún módulo a través de pip porque recibo este error todo el tiempo. File “/usr/local/bin/pip”, line 5, in from pkg_resources import load_entry_point File “/usr/lib/python3/dist-packages/pkg_resources/__init__.py”, line 2927, in @_call_aside File “/usr/lib/python3/dist-packages/pkg_resources/__init__.py”, line 2913, in _call_aside f(*args, **kwargs) File “/usr/lib/python3/dist-packages/pkg_resources/__init__.py”, line 2940, […]

Keras + tensorflow da el error “sin atributo ‘control_flow_ops'”

Estoy tratando de ejecutar keras por primera vez. Instalé los módulos con: pip install keras –user pip install tensorflow –user y luego trató de ejecutar https://github.com/fchollet/keras/blob/master/examples/mnist_cnn.py . Sin embargo me da: AttributeError: ‘module’ object has no attribute ‘control_flow_ops’ Estas son las versiones que estoy usando. print tensorflow.__version__ 0.11.0rc0 print keras.__version__ 1.1.0 ¿Qué puedo hacer para […]

¿Cómo usar numpy con OpenBLAS en lugar de Atlas en Ubuntu?

He buscado una manera fácil de instalar / comstackr Numpy con OpenBLAS pero no encontré una respuesta fácil. Toda la documentación que he visto requiere demasiados conocimientos como para que alguien como yo no esté acostumbrado a comstackr software. Hay dos paquetes en Ubuntu relacionados con OpenBLAS: libopenblas-base y libopenblas-dev . Una vez que están […]

Python 3.4 y 2.7: No se puede instalar el paquete numpy para Python 3.4

Estoy usando Ubuntu 12.04 y quiero usar python 3.4 en paralelo con python 2.7. La instalación de python 3.4 funcionó correctamente. Sin embargo, no puedo instalar el paquete numpy para python 3 (y como consecuencia no puedo instalar scipy, pandas, etc.). Utilizando sudo pip3 install numpy escupe el siguiente error: File “numpy/core/setup.py”, line 289, in […]